Community
cancel
Showing results for 
Search instead for 
Did you mean: 
krzyso
Beginner
89 Views

Symbols (PDB file) not found

I've started to evaluate VTune for Windows.

When I try to use 'Advanced activity configuration' wizard to setup 'call graph' collector I see for the module to be instrumented only option for 'Minimal instrumentation' [in the explanation for the 'Max instrumentation level' I see: 'Minimal (All functions instrumentation can not be done - no debug info)' ]. Indeed, the PDB file of the instrumented application is located in different location than the application itself (there is split between binaries and symbol information: the binaries are located ina number of directories but symbols information is located in one dedicated directory). However,

- first, Ive setup in the ConfigureOptionsDirectories the Symbol files option to the directory where my PDB file is located -> it did not help to see the debug information in the wizard

- second (following the help), Ive created the _NT_ALT_SYMBOL_PATH environment variable and assign the directory with the PDB file -> it did not help to see the debug information in the wizard

- third, Ive created the _NT_SYMBOL_PATH environment variable and assign the directory with the PDB file -> it did not help to see the debug information in the wizard

- fourth, Ive copied the relevant PDB file into the directory with the instrumented executable file -> then the wizard showed All functions option.

I do not want to copy the PDB files into the locations where the binaries are located, especially seeing the potential options that should work but I do not understand why they do not work.

Any suggestions? Or maybe Ive misunderstood/misinterpreted those options?

I am playing with VTune 7.2 (build 16929). The instrumented application is an EXE type.

Regards,

Krzysztof

0 Kudos
2 Replies
David_A_Intel1
Employee
89 Views

Hi Krzysztof:
Since the initial attempt failed, the analyzer may have created some entry somewhere that so that it "remembers" that it couldn't find the PDB. You might check the "File Associations" property page (under Directories) and make sure the symbol file mapping does not say "skipped".
Also, check out the Symbol Repository property page, press Display Symbol Repository Files and "delete" the entry/entries for the module from the repository.
Then, try again. :-}
krzyso
Beginner
89 Views

Hi Dave,

Thank you very much for the answer and tips in it. However, I've checked "File Associations" and 'Symbol Repository" but both these locations were empty, so there were no 'remembered' settings. Fornow I've decided to simply copy the PDB files into appropriate locations and in the meantime I am searching for the solution (because I cannot imagine that such a basic functionality is not working - I think, I miss somewhere some simple setting).

Anyhow, once more thanks Dave for the response and in case you have some additional ideas, do not hesitate - they are more than welcomed ;-)

Regards,

Krzysztof

Reply