Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cole_b_
Beginner
108 Views

System Crash when running General Exploration test

I have been using the VTune Amplifier XE 2016 for Linux to test some applications with our Celeron J1900 chip. When I run the general exploration test, the whole system freezes permanently forcing me to power cycle the system. Other tests seem to work fine.

Any ideas on what could be happening? Are there logs I can check?

0 Kudos
9 Replies
Peter_W_Intel
Employee
108 Views

Did you mean that you can run advanced-hotspots on same platform without problem? Celeron J1900 is Bay Trail architecture, are you sure that you work in last VTune(TM) Amplfier XE 2016 Update 2? Use "-knob enable-stack-collection=false".

If the problem can be repeated, set "export AMPLXE_LOG_LEVEL=DEBUG" first, then rerun general-exploration, log file should be under /tmp/amplxe-log-$user. Please attach this for investigating. Thank you.

 

cole_b_
Beginner
108 Views

Yes, I am using 2016 update 2. Advanced hotspots works every time but general exploration does not. I am using the gui, when do i run "-knob enable-stack-collection=false"? 

I tried to collect logs, but when it freezes, i have to restart the whole system and then the log files are no longer in tmp.

Peter_W_Intel
Employee
108 Views

If you use command line, option "-knob enable-stack-collection=false" is default. Simply use - "amplxe-cl -c general-exploration -- application".

> I tried to collect logs, but when it freezes, i have to restart the whole system and then the log files are no longer in tmp.

Please try:

1) export AMPLXE_DEBUG=1
2) export AMPLXE_LOG_LEVEL=DEBUG
3) export AMPLXE_LOG_DIR=<dir>
Then, run general-exploration, can you find log in <dir>? Also, attach result directory (which is under current directory)

Also, you can try to use events of your interest to do sampling, know what supported events are:

>amplxe-cl -collect-with runsa -knob event-config=?

Then use, "amplxe-cl -collect-with runsa -knob event-config=evt1,evt2,...  -- application." - can it reproduce the issue, same as general-exploration?

 

 

 

cole_b_
Beginner
108 Views

I apologize as I've been busy the last week.

I ran the general-exploration test a few times with logging and never saw a crash. I then tried the GE test from the GUI with logging enabled. It didn't crash the first time, but the second time i ran the test the system crashed. I attached all the logs from running this test. You can see where it crashes at the end of "amplxe-2016.03.09-14h01m27s.3483.log". When I look at the log on the machine it happened, it repeats "\00\00\00\00\00" over and over again. I'm not seeing that after I transferred the files, but everything else is the same. When it crashes, it always seems to be at the end of data collection. 

It seems that it is only an issue for the GUI meaning using the command line is an acceptable workaround. It would still be nice to understand why the GUI crashes. Thanks!

Peter_W_Intel
Employee
108 Views

It is OK to use general-exploartion in command line with log enabled as a temp workaround. I have escalated your logs to developer to investigate why using GE on GUI caused crash. Will get back to you soon.
Vitaly_S_Intel
Employee
108 Views

Will you please check if you have option "Collect stacks" turned off when you start GE analysis from GUI?

Also, can you please add the following option to your command line version and try again without logging enabled: -data-limit=500

Peter_W_Intel
Employee
108 Views

@ cole b,

Can you please try suggestions from Vitaly? It seemed that GE analysis with call stack enabling failed in BayTrail platform on GUI. Was it due to resource limitation if you worked on Visual Studio*? How about running standalone VTune application? Command line for GE analysis with call stack enabled? Option "-data-limit=500" also is good option to know if no space in disk, you may use "-duration 30" to stop GE analysis, either.

If you have no time to verify above, I may close this thread after five business days (You can input new comments in future, when you have time).

My two cents are (as a workaround) :1) Use command line instead of GUI. 2) Don't run with call stack enabled if unnecessary 3) If use call stack enabled, you may change sample interval to 10ms (modify SAV) - since stack walk may take more CPU time, reduce samples. 4) Don't run sampling collection too long, use option "-duration n" or "-data-limit=n" if possible.

cole_b_
Beginner
108 Views

Hello, I have switched projects and haven't had time to look more into this. Unfortunately, our 30 day evaluation period just ended. I may come back to this if we end up using VTune.

When I ran the tests, VTune was the only program running and collect stacks was not checked. Using the command line was an acceptable work around as it collected the wanted data. 

Thanks for the help! Sorry I couldn't help figure this out.

Peter_W_Intel
Employee
108 Views

OK. Thanks for your quick response...I am glad that you can accept command line as workaround. I look forward to see your working on VTune again in future:-)

Reply