Community
cancel
Showing results for 
Search instead for 
Did you mean: 
pacard
Beginner
140 Views

Thread profiler with MKL: Outdated or Non-existent OpenMP libraries: libmkl.so

I am using Thread Profiler to analyze a program which uses MKL. But after I launch the activity, Thread Profiler complains about "Outdated or Non-existent OpenMP libraries: /opt/intel/mkl/8.0.2/lib/32/libmkl.so". I searched around, but didn't find any solution.
I am using icc 9.1.038 on Fedora Core 2.
The version of MKL is 8.0.2.
And I linked with "-lmkl -lvml -openmp_profile".
The machine has 2 Xeon processors with two cores each.
Any help would be appreciated.

Message Edited by Pacard on 06-23-200601:29 AM

0 Kudos
3 Replies
TimP
Black Belt
140 Views

In case no one reports dealing with this exact problem, I would suggest checking that you don't use a libguide from the MKL installation, either at link or at run time. You should be using the one from the icc library installation. If you will always be using icc, you could move the libguide files out of your MKL installation, to assure they will not be used. They should be used only when a non-Intel compiler is in use. The recommended method is to avoid giving the MKL library directory in a -L path. Instead, specify the full path name of each MKL library you require.

If there is an outdated library, it would be the libguide in the MKL installation, where the one in the icc is more up to date.

If this does not correct the problem, MKL 8.1 evidently is more up to date.

Message Edited by tim18 on 06-23-200606:28 AM

pacard
Beginner
140 Views

Thanks for your reply.

I moved the libguide files out of the folder, deleted -L, and specified the full path name of libmkl.so and libvml.so, but the problem remains.

The full errormessage is as follows:

Multiple OpenMP* Linkage conventions were found in the Intel Thread Profiler (OpenMP*) collector's modules of interest:

Profiled OpenMP* DLL: libguide_stats.so (Linked with -openmp_profile -i_dynamic) /home/user/PLSA/PLSACluster/PLSACluster

Outdated or Non-existent OpenMP* libraries: /opt/intel/mkl/8.0.2/lib/32/libmkl.so

This is not supported. Running the activity may cause a fatal error. To fix the problem, relink your application and modules of interest so that they all use the sam OpenMP* library.

pacard
Beginner
140 Views

I have just tried MKL 8.1, but the same message appears. :-(
Reply