Community
cancel
Showing results for 
Search instead for 
Did you mean: 
115 Views

UE Exploration yields wrong results in a server

Jump to solution

Hey,

I am using ue analysis to profile a set of applications with different hardware. So far, I've used Ubuntu 18.04 with
a) Intel(R) Xeon(R) CPU E5-2640 v3 @ 2.60GHz
b) Intel(R) Xeon(R) CPU E5-2660 v3 @ 2.60GHz
c) Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz

When I run my applications with the less powerful CPU on my desktop, the results are showing what I expect and everything works fine.

However, when I run them to the servers (each has two sockets of either CPU a) or b)), the results become weird. I've run more than 100 different workloads (applications and configurations) that return a Core Bound metric equal to 0. But that's not the only problem. While, Memory Bound is a sub-category of BE-bound, it shows that its pipeline percentage is higher than BE-Bound, which results in a graph with components that add up to more than 100% of pipeline slots! E.g., I end up having Bad-Spec=3.6%, FE-Bound=7%, Retiring=27.4% and Memory-Bound=75%, which gives me 113%!

Has anyone seen anything similar? Do you have any suggestions on how I could resolve this? I've already tried upgrading the kernel...

Cheers,
George

0 Kudos
1 Solution
Dmitry_R_Intel1
Employee
115 Views

In the screenshot you attached I don't see MUX Reliability metric at all. Are you using driver-less mode? Can you try loading VTune drivers and check if problem persist?

Also it can be interesting to switch 'Collection mode' to 'Summary' on the UE analysis configuration and see if it changes something (this will cause collection to be done in counting mode instead of sampling).

View solution in original post

4 Replies
Dmitry_R_Intel1
Employee
115 Views

What is VTune version you are using?

What is the value of MUX Reliability metric?

Was HyperThreadin enabled on you machine? If yes - can you disable it in BIOS and re-run profiles?

Can you share some of wrong VTune results you collected?

115 Views

The version is vtune_amplifier_2019_update8.

At least for the values I want the MUX metric seems ok and I've disabled hyper-threading.

I've also included an example. Thx!!

Dmitry_R_Intel1
Employee
116 Views

In the screenshot you attached I don't see MUX Reliability metric at all. Are you using driver-less mode? Can you try loading VTune drivers and check if problem persist?

Also it can be interesting to switch 'Collection mode' to 'Summary' on the UE analysis configuration and see if it changes something (this will cause collection to be done in counting mode instead of sampling).

View solution in original post

115 Views

Switching 'Collection mode' to 'Summary' seems to be working in most cases now.

Thank you!

Reply