Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
90 Views

VTune 2017: cannot locate debugging symbols for application

Jump to solution

Hi, I am using Intel VTune Amplifier 2017 on my Ubuntu 16.04 64-bit system. I compiled an executable emsim_seq using GCC 5.4.0 with -pg -O0 flags. This generates emsim_seq.d and emsim_seq.o files in the same folder as the executable. But during Basic Hotspot analysis, I get an error

Cannot locate debugging symbols for file emsim_seq

I have configured the working directory to be the same as application directory. How do I resolve this?

0 Kudos

Accepted Solutions
Highlighted
Black Belt
90 Views

If you wish to compare gprof vs vtune you may need to switch between pg and -g.

View solution in original post

0 Kudos
3 Replies
Highlighted
Employee
90 Views

 This message means that there is a link to a separate (symbol) file with debugging information in the emsim_seq binary but VTune failed to find or validate the symbol file. Following command should dump name of the symbol file: objdump -s -j .gnu_debuglink emsim_seq. If the symbol file directory is not the same as the binary file directory, it should be added to VTune Binary/Symbol Search paths (see more details in VTune help). Symbol file should contain DWARF debug. sections like .debug_<info|line|frame etc> (readelf –S <symbol_file>).

Can you reproduce it on a simple “Hello world” application? Do you have any build scripts?  “gcc -pg -O0” doesn’t create a separate file with debugging. Info.

0 Kudos
Highlighted
Black Belt
91 Views

If you wish to compare gprof vs vtune you may need to switch between pg and -g.

View solution in original post

0 Kudos
Highlighted
Beginner
90 Views

Thanks! Using only the -g flag resolves the issue :).

0 Kudos