Community
cancel
Showing results for 
Search instead for 
Did you mean: 
yu__frank
Beginner
86 Views

VTune Amplifier's running can not end.

I used Amplifier try analysis a sample program. but the Amplifier can not end when it start analysis.

My program is very sample.

Cmd line output some error information: Xlib: extension "RANDR" missing on display 127.0.0.1

Amplifier version is : 2017 r2

My license is professional edition.

0 Kudos
3 Replies
Vitaly_S_Intel
Employee
86 Views

Hi Frank,

Please check that you're running VTune under the same environment as you run application - try to use the same terminal. If your application requires additional environment variables (say, DISPLAY), you may use VTune settings to set it up for the analysis (for local collection) or just create script that defines the environment and invokes your application and use this script as application in VTune GUI/CL.

You may also consider attaching to the application where it is run regularly.

yu__frank
Beginner
86 Views

Hi Vitaly Slobodskoy,

I am used a sample code that only has a line "printf("hello\n");"

Also the VTune Amplifier can not end.

please help me.

os : linux centos6.5 64x

 

 

yu__frank
Beginner
86 Views

Hi All, 

 

I have solved this problem!

 

I did not find the root cause, I described the process of solving the problem, I hope to help everyone.

 

I found this problem related to the option when installing the system.

Here is my change, not sure which one is correct.

1.use disk only one.

2.choose 'mini desktop'

 

Reply