Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
74 Views

VTune GUI Unable to initialize gtk

Jump to solution

Hi guys,

I just started exploring VTune trying to identify the hotspot in my program. After I did the "source", I typed "amplxe-gui", but it gave me:

"Error: Unable to initialize gtk, is DISPLAY set properly?"

I searched this problem for a long time but could not find anything related. Can any one help me?

Thanks a lot!

Terrence

0 Kudos

Accepted Solutions
Highlighted
Employee
74 Views

Hi Terrence,

Are you working right on the system or using VNC or X forwarding ? Which OS is this system running?

Which script did you "source" before running amplxe-gui? Can you skip it and just run amplxe-gui by absolute path?

Also please make sure you unset DISPLAY environment variable before running amplxe-gui.

View solution in original post

0 Kudos
5 Replies
Highlighted
Employee
75 Views

Hi Terrence,

Are you working right on the system or using VNC or X forwarding ? Which OS is this system running?

Which script did you "source" before running amplxe-gui? Can you skip it and just run amplxe-gui by absolute path?

Also please make sure you unset DISPLAY environment variable before running amplxe-gui.

View solution in original post

0 Kudos
Highlighted
Beginner
74 Views

Hi Vitaly,

Thanks for your quick response!

I managed to make it work by installing quartz, then I do the following:

ssh -X ID@server.addr

source /home/opt/intel/vtune_amplifier_xe_2015.1.1.380310/amplxe-vars.sh

amplxe-gui

 

Then everything works! I am working from MacOSX and I am trying to submit the job to scheduler now.

 

Thanks again!

0 Kudos
Highlighted
Employee
74 Views

Share with more people - if they have similar issue.

Here is my inputs: If you use standard Linux distro operation system, or installed GTK and X11 library correctly. amplxe-gui should work. One possibility is that you used vnc server/client for remote access, if you start-up vncserver by root user, use console in in vnc client with non-root user then run amplxe-gui, it will report, Unable to initialize gtk. Just use root user instead.

[Terrence C told me via message] Yes, later on I installed X11 library and everything is fine! 

0 Kudos
Highlighted
Beginner
74 Views

Terrence C. wrote:

Hi Vitaly,

Thanks for your quick response!

I managed to make it work by installing quartz, then I do the following:

ssh -X ID@server.addr

source /home/opt/intel/vtune_amplifier_xe_2015.1.1.380310/amplxe-vars.sh

amplxe-gui

 

Then everything works! I am working from MacOSX and I am trying to submit the job to scheduler now.

 

Thanks again!

 

 

I don't get it. I have the same problem with you. What kind of quartz did you install?

0 Kudos
Highlighted
74 Views

Hello, 

I am also facing the same issue and tried to resolve it using above suggestion (by installing quartz) but didn't get any success. 

Can someone provide some details on this ?

0 Kudos