Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
4728 Discussions

VTune Profiler Visual Studio 2019 and 2022 IDE Integration Stuck on Loading or Crashing

tedgress-daz
Beginner
600 Views

Hi,

 

We are trying to use the IDE integration of VTune Profiler to determine hotspots in our primary product. I have went through a variety of steps to fix the problem we are having that seems to be isolated to my individual laptop. I have both Visual Studio 2019 and 2022 installed and VTune installed for both of them as well as some older version of Visual Studio installed beneath since we are still dependent on the v100 toolset for a few of our projects. 

 

The problem that is occurring on my particular machine is that when trying to launch the profiler from within Visual Studio or even when trying to look at the about pane from the configuration button causes a pane to open, get stuck on loading, or sometimes Visual Studio will just crash entirely. We use CMAKE as our cross-machine project generation tool and I have tried both reconfiguring/regenerating our CMAKE solutions, rebuilding the projects, reinstalling VTune, Updating Visual Studio to latest version, removing the Visual Studio Installer - reinstalling it - and performing a repair, and a host of other solutions to debug/fix this problem. It has not solved any issues.

 

VTune GUI works perfectly fine as a stand-alone application. It is only the integration of VTune into Visual Studio, both 2019 and 2022 which is problematic and causes the same issues in both IDEs. 

 

I'd like some help in trying to solve this issue and I can provide whatever hardware or software information necessary to resolve this issue. Thanks.

 

(Ted) Walter Gress

Daz Productions Inc.

0 Kudos
12 Replies
AlekhyaV_Intel
Moderator
583 Views

Hi,

 

Thank you for posting in Intel Communities. We could reproduce your issue. Please follow the below workaround and let us know if the issue still persists:

 

  1. Update Visual Studio 2019 & 2022 from Visual Studio Installer as follows:Vtune20222019IDE1.PNG
  2. Open oneAPI Installer from the path <Intel oneAPI installed directory> : /intel/oneapi/installer/installer.exeVtune20222019IDE2.PNG
  3. Repair Intel Base Toolkit by clicking on Modify -> RepairVtune20222019IDE3.PNG
  4. If repairing doesn't work, please re-install the Base toolkit.

 

If this resolves your issue, make sure to accept this as a solution. This will help other users with similar issue.

 

Thank you,

Alekhya

 

tedgress-daz
Beginner
554 Views

Hello,

 

I went through these steps once before, I wen through them again for brevity. Your steps did unforutnately not resolve the issue. Coudl you please provide further assistance?

 

-Ted

ArpanB_Intel
Moderator
526 Views

Walter, thank you for the update.


We will move your query to the respective forum for further support on the performance issues you are encountering.


ArpanB_Intel
Moderator
516 Views

Walter, please do the following for both the Visual Studio 19 and Visual Studio 22 versions>


  • On the tabs at the top, go to Help tab
  • Select the option About Microsoft Visual Studio
  • From the dialog box that appears, select the Copy Info button
  • Paste the info for both the VS versions in a .txt file and share it with us


We would need to confirm the status of the integration.


tedgress-daz
Beginner
496 Views

text is attached.

 

Thanks,

 

Ted Gress

Daz Productions

ArpanB_Intel
Moderator
486 Views

Walter, we have shared some information with you privately. Please check your inbox for further updates.


Jeffrey_R_Intel1
Employee
368 Views

Hello Walter,

Please try deleting %AppData%\Roaming\Intel\VTune\settings\certificates or %AppData%\Intel\VTune\settings\certificates (depending on your configuration) and restart MSVS and the VTune Profiler MSVS plug-in.

Thank you.


Jeffrey_R_Intel1
Employee
216 Views

Hello Ted,

Did you get a chance to try the recommendation in my previous response? Did that help?

Thank you.


tedgress-daz
Beginner
100 Views

I did try deleting the certificates folder from AppData like you suggested, but after launching Visual Studio 2019 again I had the same response from vTune unfortunately.

Jeffrey_R_Intel1
Employee
64 Views

Hello Ted,

Per https://community.intel.com/t5/Analyzers/Configure-Analysis-window-not-loading/m-p/1260559#M20100

please try deleting "%appdata%\intel" and "%appdata%\Intel VTune Profiler" and restarting MSVS and VTune Profiler.


Jeffrey_R_Intel1
Employee
36 Views

Hello Ted,

Can you provide a sample MSVS project to reproduce this issue? Thank you.


Jeffrey_R_Intel1
Employee
15 Views

Hello Ted,

To get logs from VTune VS extension:

Set VTUNE_AMPLIFIER_LOG_DIR environment variable to the existing directory.

Logs are available for viewing just as Visual Studio is closed.


If you are able to generate logs in the failing case, please provide them here.

Thank you.


Reply