Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
16 Views

VTune XE assertion error on Sandy Bridge processors with 2011 and 2013 versions

We are consistently seeing an assertion error when running VTune XE for Linux HotSpot analysis on Sandy Bridge based processors.

VTune versions: vtune_amplifier_xe_2011u8, vtune_amplifier_xe_2013u3

Linux version: Red Hat Enterprise Linux Server release 6.2 (Santiago)

Kernel: 2.6.32-220.23.1

Processor: Intel(R) Xeon(R) CPU E5-2670 0 @ 2.60GHz

Error code:

Assertion '(4 ) + (2 +2 +4 +4 + cpu_no*(2 +leaf_no*(2*4 +4*4 ))) == pos' failed. Please contact the developers.

Assertion '(4 ) + (2 +2 +4 +4 + cpu_no*(2 +leaf_no*(2*4 +4*4 ))) == pos' failed. For more information, please visit the technical support forum at https://software.intel.com/sites/support/

We do not see this with Red Hat 5 / VTune 2011 / Nehalem processors. Can someone shed some light on the error, if it's origin is VTune or the Sandy Bridge architecture, it's severity, and if there is a work-around or fix in the works for it?

Thank you.

0 Kudos
4 Replies
Highlighted
Employee
16 Views

Have you tried latest VTune(TM) Amplifier XE 2013 Update 4?

Are you sure that you used Hotspots collector, not Lightweight-hotspots? What was command line? 

If you still have this problem after using U4, can you attach result directory?

0 Kudos
Highlighted
Beginner
16 Views

VTune 2013 Update 4 seems to correct that issue.  Thank you. However, now I am seeing:

Error 0x40000026 (Database interface error) -- Cannot run data transformation `Compute CPU Usage'

When trying to run a summary report on the data collection. I appreciate your assistance.

0 Kudos
Highlighted
Employee
16 Views

cabeggi@sandia.gov wrote:

VTune 2013 Update 4 seems to correct that issue.  Thank you. However, now I am seeing:

Error 0x40000026 (Database interface error) -- Cannot run data transformation `Compute CPU Usage'

When trying to run a summary report on the data collection. I appreciate your assistance.

It seemed that data collection was OK, and met error when ran:

amplxe-cl -report summary -r result-directory

Is the problem only for summary? Can you do - "amplxe-cl -report hotspots -r result-directory"?

Is it possible that you can attach result directory for invesigating? Thank you.

0 Kudos
Highlighted
Beginner
16 Views

I was able to to 'amplxe-cl -report hotspots -r result-directory.' Thank you, this is resolved.

0 Kudos