Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
4679 Discussions

VTune does not see processes inside Docker containers

Breyer__Markus
Beginner
186 Views

EDIT: I figured this out. There are only a few debug symbols still missing at this point.

Hi - I am trying to run a system wide profile on a Linux machine that also runs a number of Docker containers. Unfortunately, VTune does not see any of the processes in side the Docker containers, let alone finds any debug information for them. The time spent in those processes is labeled as "Outside any known module" which is a problem as this is 90% of the time.

The processes running inside Docker containers show up in the hosts process list, e.g. using htop I can see them and how much CPU they are consuming. htop shows their command line, and the path to the executables is mapped so it is valid on both host and container. Just VTune ignores them.

I run VTune Amplifier using sudo. No errors are reported before or after performance analysis (except that debug symbols cannot be found for a number of system libraries which is expected).

How can I get this to work? Can I run Docker in a specific mode to is more friendly to profiling?

Thanks for any help.

0 Kudos
0 Replies
Reply