Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Nikita_Tropin
Novice
57 Views

VTune evaluation errors

Hello,

Recently I've downloaded 30-day evaluation version of VTune for Windows (vtune91_008_win.exe) and installed it on my WinXP PC with Visual Studio 2008 integration. I have some problems in using this software:

1. When I launch VTune and click Quick Performance Analysis Wizard with all options (sampling data, counter monitor data, call graph data) I have an error:

"Call Graph Collector configuration can not be done due to the following reason:
Invalid "Analyzer.dll"
Check that it is present in "Analyzer/bin" directory and registered.
Also check that "Analyzer/bin" directory is in path."

I've found that there is no Analyzer.dll in my C:\\\\Program Files\\\\Intel\\\\VTune\\\\Analyzer\\\\bin directory - is it a limitation of evaluation version?

2. Now when I open no matter what project in Visual Studio 2008 I have the following errors:
E:\\\\vttbuild\\\\workspaces\\\\vtune_linux_0\\\\source\\\\vpeWin32Common-1.1.4-31272\\\\src\\\\EmbeddedHelp\\\\EmbeddedHtmlHelp.cpp
E:\\\\vttbuild\\\\workspaces\\\\vtune_linux_0\\\\source\\\\vpeWin32Common-1.1.4-31272\\\\src\\\\ProjectNavigator\\\\VTProjectNavigator.cpp
E:\\\\vttbuild\\\\workspaces\\\\vtune_linux_0\\\\source\\\\anprodinfo-1.2.15-31297\\\\src\\\\windows\\\\ProductInfoClient.cpp

If I click Quick Performance Analysis button in Visual Studio then, I have an error "Wizard can not be run because valid VTune Performance Analyzer license wasn't found." Can this happen because I use licensed Intel C++ and Intel Frotran compilers with license file, and VTune tries to find information about it's license there? During the installation of VTune I entered the evaluation serial number.

P.S. By the way, when I click Preview during creating new thread in this forum, the symbol "\\" is not appearing in the post, but "\\\\" appears as "\\", so I decided to change all "\\" to "\\\\". But when I submit the post, "\\\\" appears as "\\\\".
0 Kudos
3 Replies
David_A_Intel1
Employee
57 Views

No. The only limitation with the evaluation version is controlled by the license and it limits you from saving projects and their results.

I sounds like your installation is badly corrupted. Please uninstall and then, ensure that your anti-virus software is disabled and that you are installing on a supported OS, then re-install the software. You should not be getting any of the messages you reported.

Also, to test your installation, please use the Sampling Wizard and/or Callgraph Wizard.
Nikita_Tropin
Novice
57 Views

Well, after computer reboot my problems with VTune magically dissapeared and now everything works fine. I guess, VTune installer should propose to restart PC after installation to eliminate such cases.
David_A_Intel1
Employee
57 Views

We used to require a reboot, but with Windows* XP and above system modules can be dynamically loaded and it is not longer required. Beside, the files you references are not system modules, so I'm not sure what happened with your installation. However, I'm glad it work now. :-)
Reply