Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Lin_L_Intel
Employee
227 Views

[Vtune 18.0]Vtune option -target-tmp-dir doesn't work.

Jump to solution

Reproduce command:

amplxe-cl -quiet -collect-with runsa -knob event-config=CPU_CLK_UNHALTED.THREAD,CORE_POWER.LVL0_TURBO_LICENSE,CORE_POWER.LVL1_TURBO_LICENSE,CORE_POWER.LVL2_TURBO_LICENSE -data-limit=0 -finalization-mode=none -result-dir="/export/users/linliu/vtune" -target-tmp-dir="/export/users/linliu/xxx" -no-summary -- ls

Vtune still writes temporary files to /tmp directory instead of the directory I specified. Temporary files of vtune on our benchmarks are too large to be stored in the root directory. As a result, it always throws error "no space left on device".

Anybody knows about this problem? Much appreciated!

0 Kudos
1 Solution
Kirill_U_Intel
Employee
227 Views

ok.

Could you try to increase sampling interval? just add '-knob sampling-interval=10'

BTW, what is the size of trace for your benchmark on 5 secs collection with default and with sampling-interval options?

Kirill

 

View solution in original post

7 Replies
Kirill_U_Intel
Employee
227 Views

Hi Lin.

Sorry for confusion.  '-target-tmp-dir'  option is used for remote collection case only.

Could you set TMPDIR directly and retry your collection

TMPDIR="/export/users/linliu/xxx" amplxe-cl -quiet -collect-with runsa -knob event-config=CPU_CLK_UNHALTED.THREAD,CORE_POWER.LVL0_TURBO_LICENSE,CORE_POWER.LVL1_TURBO_LICENSE,CORE_POWER.LVL2_TURBO_LICENSE -data-limit=0 -finalization-mode=none -result-dir="/export/users/linliu/vtune" -no-summary -- ls

Thanks, Kirill

Kirill_U_Intel
Employee
227 Views

VTune just uses system tmp dir in case of local collection. if TMPDIR is not set we use /tmp directory by default

Kirill

Lin_L_Intel
Employee
227 Views

KIRILL U. (Intel) wrote:

Hi Lin.

Sorry for confusion.  '-target-tmp-dir'  option is used for remote collection case only.

Could you set TMPDIR directly and retry your collection

TMPDIR="/export/users/linliu/xxx" amplxe-cl -quiet -collect-with runsa -knob event-config=CPU_CLK_UNHALTED.THREAD,CORE_POWER.LVL0_TURBO_LICENSE,CORE_POWER.LVL1_TURBO_LICENSE,CORE_POWER.LVL2_TURBO_LICENSE -data-limit=0 -finalization-mode=none -result-dir="/export/users/linliu/vtune" -no-summary -- ls

Thanks, Kirill

Hi Kirill,

Thanks for your response. It works but I found even if I get 100G for my own directory, the space are all eaten by vtune. And the result directory takes over 80G. I wonder why it is such huge since I only collect 4 events. My benchmarks run like 15 minutes.

Best Wishes,

Lin

Kirill_U_Intel
Employee
227 Views

Hi Lin.

Could you tell me what is count of core on your system?

Could you share results directory for just 'ls' collection?

Does your benchmark utilize all cpus on system?

Thanks, Kirill 

Lin_L_Intel
Employee
227 Views

KIRILL U. (Intel) wrote:

Hi Lin.

Could you tell me what is count of core on your system?

Could you share results directory for just 'ls' collection?

Does your benchmark utilize all cpus on system?

Thanks, Kirill 

Hi Kirill,

I use Intel(R) Xeon(R) Platinum 8180 CPU @ 2.50GHz  CPU with 56 physical cores. I am running the SPEC INT RATE benchmarks and all cpus are used.

The result directory of 'ls' collection is in attachments.

Best Wishes,

Lin

Kirill_U_Intel
Employee
228 Views

ok.

Could you try to increase sampling interval? just add '-knob sampling-interval=10'

BTW, what is the size of trace for your benchmark on 5 secs collection with default and with sampling-interval options?

Kirill

 

View solution in original post

Lin_L_Intel
Employee
227 Views

I tried and it reduced to 10G with -knob sampling-interval=10. 

Do you mean -duration=5? I used -duration=5 and -knob sampling-interval=10 and the result directory is about 97M on our benchmarks.

Thank you again Kirill, you really helped a lot!

Best Wishes,

Lin

Reply