Community
cancel
Showing results for 
Search instead for 
Did you mean: 
craigmcn
Beginner
40 Views

Vtune 2015 Update 2 stopped working on some VS2010 solutions

Hi,

I've just upgraded to Update 2 (from update 1) running inside VS2010.  On some C++ solutions I'm finding the New Analysis and Project properties greyed out and I can run any analysis on those projects.  The solutions still have the the results files from the previous version and I can open those fine.  On other solutions I've checked the New Analysis button isn't greyed out and I can run those without problem.

This solution has a single executable and 5 static libraries linked into it.   They've all got the same compiler settings (debug info on in C++ and debug output on in the linker).   I can run an analysis on the .exe file by loading that exe into a new solution in VS2010 so it appears the app has everything required in it.  Have any requirement changed in the projects, or is there any other reason I wouldn't be able to run an analysis on this solution any more?

Thanks,

Craig.

0 Kudos
5 Replies
Peter_W_Intel
Employee
40 Views

In order to distinguish if it is the VS2010 related issue for Update 2, you can run standalone VTune application (Update 2) to open the vtune project (file name is "???.amplxeproj" - vtune project file) which was generated by Update 1.

If you ensure that .amplxeproj file can be opened by Update 1, and be incompatible to Update 2 (grayed out for project properties). Please attach this file. Thank you. 

craigmcn
Beginner
40 Views

Sorry, slightly different story, it turns out it's an older VTune 2011 update 7 project (I've been using 2015 U1 on other projects) but the problem remains anyway.    I've attached that older amplexeproj file

I've also moved away the existing "My Amplifier XE results" folder to try and recreate a new vtune project but no luck with that, the new analysis and option buttons are still disabled (though all my previous data and the results folder are gone from the solution.)

Thanks,


Craig.

 

 

 

 

Peter_W_Intel
Employee
40 Views

I'm using VTune(TM) Amplifier XE 2015 Update 2 (standalone app) to open your attaching config.amplxeproj (2011 version) - no problem to open this and view project properties. I also can modify this project to change target application "C:\Craig\f1bin\2012\F1.exe" to my application, then run VTune analysis again.

Dmitry_K_Intel1
Employee
40 Views

I have had a chance to play with VTune(TM) Amplifier XE 2015 Update 2 under VS2010. I was able to create a dummy win32 project with the same project hierarchy Craig had(C:\Craig\F1\App\App.vcxproj). Next I replaced newly created .amplexeproj project on my machine by the one attached by Craig and still have not met any issues with the buttons 'enabled' state and ability to start any collection.

I suspect something which depends on VS solution/project files.

Craig, what happen if you create new solution and add the existing VS projects (one by one) from the initial solution to the newly created solution? Are the 'new analysis' and 'option' buttons still disabled?

Peter_W_Intel
Employee
40 Views

@Ahmed S.

Please verify problems with latest product VTune(TM) Amplifier XE 2016 Update 1 - 2015 early version cannot support latest Intel new processors as well as new operating systems, with event-based sampling collections.
 

Reply