Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
290 Views

Vtune GUI unable to initialize ( Trace/breakpoint trap )

Hi Support team,

I am writing to ask how to initialize Vtune GUI program.
I have installed vtune_profiler_2020.2.0.610396 and I tried  to initialize vtune_gui command.

My command is below.

# Command
source vtune-vars.sh
vtune-gui

# Response(Error)
Trace/breakpoint trap

When I search the error messesage on Internet, I couldn't find the error related to Vtune.
By the way, I can intitialize Advisor and Inspector.

Please share if there is a way to check if I'm doing the wrong.
Also, if I have to have a GUI library Vtune need, please tell me.

Additionally, in the current system, all the locations that I can access use the shared file system (GPFS).
 
If this is the case, if I run the model with the VTUNE option added, it will take considerably more time on I/O than if I just did it.
 
Is there any other way to solve the above problem (adjusting the number of files, profile only on the master node)?

Thank you.
 
0 Kudos
5 Replies
Highlighted
Moderator
275 Views

Hi Kihang,


Thanks for reaching out to us. We will be very happy to help you with your issue.Could you please share the below details with us so that we can analyze the issue in detail.


1)Give more information about the environment in which you are working,is it Windows or Linux-based OS. In case it's Linux based, specify the exact OS version(Ubuntu/Debain/CentOS etc)

2)Please confirm whether your are doing X11 forwarding to launch the Vtune-gui


Also, could you please check the Command Line Interface(CLI) for vtune works for you. The vtune command line interface provides an extensive set of options that allow you to perform almost every task that might be performed through the GUI.Please refer to the below documentation for more information. https://software.intel.com/content/www/us/en/develop/documentation/vtune-help/top/command-line-inter...


Regards,

Chithra


0 Kudos
Highlighted
Beginner
262 Views

Hi Chithra,

Thank you for your kind response.

Here is my answer to give more information.
1) I worked in CentOS Linux 7.6.1810.
2) As I can initialize Intel Advisor and Inspector, I think I am doing X11 forwarding well.
3) Also I can use vtune-cli to collect hostpot analysi and report as well.
4) Addtionally, when I installed parallel studio, I encoutered GTK library issue.

Sorry for the late response.
I will do our best to respond quickly to your business hours.

Thanks

0 Kudos
Highlighted
Moderator
141 Views

Hi Kihang,

 

Thanks for the details shared. Please refer to the below documentation for required Packages of Intel VTune Profiler GUI and please confirm whether all the pre-requisites for VTune GUI on CentOS satisfied.

https://software.intel.com/content/www/us/en/develop/documentation/vtune-install-guide-linux/top/pre...

Vtune requires not only GTK but few other libraries also. Please let us know the update after trying this.

 

Regards,

Chithra

 

0 Kudos
Highlighted
Moderator
121 Views

Hi Kihang,


Has the solution worked for you? Please let us know if the issue still persists.


Regards,

Chithra


0 Kudos
Highlighted
Moderator
99 Views

Hi Kihang,

 

We are assuming that the solution provided was helpful for you. We would no longer be monitoring this issue. Please raise a new thread if you have further issues.

 

Regards,

Chithra

 

0 Kudos