Community support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
4964 Discussions

Works from command line, not from GUI

Recently, I installed this software and I wanted to check whether I had a data race or some other bug in my program with the thread checker. When I ran it from the graphical user interphace, set up the new project, compiled the c++ code with icpc and ran it through the thread checker, it said it didn't detect any problems and also that it did not find any other threads. It was running the program serially so of course it couldn't find any data races. It also seemed to not be loading the omp library (?).
Anyways, the error i got was this:
Threading error analysis: started
Result file: [/home/enterprice/intel/inspxe/projects/PipePract/r003ti3/r003ti3.inspxe] 
Loaded module: /home/enterprice/Development/OMP_Exercises/OMPPIPESFORINTEL. 
Loaded module: /lib64/ 
Unloaded module: /home/enterprice/Development/OMP_Exercises/OMPPIPESFORINTEL. 
Unloaded module: /lib64/ 
Process /home/enterprice/Development/OMP_Exercises/OMPPIPESFORINTEL (PID = 5516) has terminated. 
Warning: Failed to find more than one thread. Ensure that your program is multithreaded.
Application exit code: [127] 
Result file: [/home/enterprice/intel/inspxe/projects/PipePract/r003ti3/r003ti3.inspxe] 
Threading error analysis: completed
I tried at the same time opening this software from the command line and when tried it again, it ran it in parallel and found a few data races and an exception. Someone suggested that maybe it was because it was forking processes and from the command line it could inherit/see the missing library and loaded it, but it couldn't do the same in the graphical user interphace. However, when they tried to find the library, it was at the root so it should have been seen even from the GUI. That may not be the best description but hopefully someone might have some ideas based on the nature of the problem and the error message.
0 Kudos
1 Reply

Most likely you have to use icpc environment then you can build code by using OpenMP: for example
$ source /opt/intel/composerxe-2011.4.191/bin/ intel64
You might use "-openmp-report" to know if paralleleling works or not.

After building program, this program shouldbe invokedon icpc environment (or invoked by Inspector XE). Otherwise, omp library will be missed.

This is not the Inspector XE issue.
Note that this is Inspector XE forum, please go compiler forum to raise more questions.

Thanks, Peter

0 Kudos