Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
4682 Discussions

amplxe: Error: [Instrumentation Engine]: Pin is out of memoryPin is out of memory

Eric_S_
Beginner
523 Views

Hello,

When I run the command line:

amplxe-cl -collect hotspots -verbose --target-process myProgram & I receive the following error:

amplxe: Collection started. To stop the collection, either press CTRL-C or enter from another console window: amplxe-cl -r /opt/intel/vtune_amplifier_xe_2016.1.0.424694/bin32/r000hs -command stop.
amplxe: Error: [Instrumentation Engine]: Pin is out of memoryPin is out of memory
amplxe: Collection detached.
amplxe: Collection failed.
amplxe: Internal Error

When I run the same command line using "advanced-hotspots" instead of "hotspots" it works.

How do I get it to work using "hotspots" and remove "Pin is out of memoryPin is out of memory"?

Please advise.

Thanks

Eric

 

0 Kudos
5 Replies
Andrey_I_Intel
Employee
523 Views

Hi Eric,

Does this happen only when attaching or with run mode too? What host OS do you use?

Could you please enable extended logging by setting environment var

export AMPLXE_LOG_LEVEL=trace

try attaching again and send us the result directory?

It would also help if you could share the application that is causing the issue to appear so that we could reproduce it.

BR,

Andrey

Eric_S_
Beginner
523 Views

Hi Andrey,

This happens when I attach to a running process.  Is run mode a different way of collecting the data?

I set export AMPLXE_LOG_LEVEL=trace and got the following(Different than Pin out of Memory):

amplxe: Collection started. To stop the collection, either press CTRL-C or enter from another console window: amplxe-cl -r /opt/intel/vtune_amplifier_xe_2016.1.0.424694/bin32/r000hs -command stop.
amplxe: Collection detached.
amplxe: Collection stopped.
amplxe: Using result path `/opt/intel/vtune_amplifier_xe_2016.1.0.424694/bin32/r000hs'
amplxe: Executing actions 100 % done
amplxe: Error: 0x40000025 (Inapplicable report) -- The report 'summary' is not applicable to the result /opt/intel/vtune_amplifier_xe_2016.1.0.424694/bin32/r000hs/r000hs.amplxe.

This is using CentOS.  Unfortunately, I won't be able to share the resultDir//application.  

Its puzzling why "advanced-hotspots" works and "hotspots" doesn't.

Please Advise.

Thanks

Eric

Peter_W_Intel
Employee
523 Views

"advanced-hotspots" doesn't use PIN technology basically, that was why "Pin is out of memory" message only appeared when using basic hotspots.

Can this problem be reproduced when using latest VTune(TM) Amplifier XE 2016?

What was the user account which launched target program? VTune should use same one for permission consideration.  

I suggest to use option "-target-pid PID" instead of "-target-process program" if you have multiple same program running. Can you use "cat /proc/meminfo" to know available memory? Please end some active processes if memory is limited then running basic hotspots.

Also check "ps -ae | grep amplxe-cl" to know if there are previous amplxe-cl remained. If any, kill them then start a new session. 

If the problem persists on, use "export AMPLXE_LOG_LEVEL=TRACE" to generate log for investigating, if you like.

Peter_W_Intel
Employee
523 Views

>amplxe: Using result path `/opt/intel/vtune_amplifier_xe_2016.1.0.424694/bin32/r000hs'
>amplxe: Executing actions 100 % done
>amplxe: Error: 0x40000025 (Inapplicable report) -- The report 'summary' is not applicable to the result 

Don't generate result under VTune's home if you didn't work as root user, do like this -

amplxe-cl -collect hotspots -verbose --target-pid PID -r /home/$User/r000hs

Israr
Employee
215 Views

Hi,

While executing 

advisor -collect survey -static-instruction-mix -project-dir ./advisor_data1 python yourscript.py

got error as:

error: advisor: Error: [Instrumentation Engine]: Pin is out of memory

 

Any suggestion, how to overcome it?

TIA

Israr

Reply