Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
26 Views

amplxe-gui XPCOMGlueLoad error

I want to use vtune.But I get following information while I start vtune with amplxe-gui. 

wj@mcc21:~$ amplxe-gui
XPCOMGlueLoad error for file /opt/intel/vtune_amplifier_xe_2016.2.0.444464/lib64/libxul.so:
libXt.so.6: cannot open shared object file: No such file or directory

0 Kudos
8 Replies
Highlighted
26 Views

Hello Ye,

What operational system do you have on the node?

Could you launch other GUI applications like Mozilla Firefox on the system?

Thank you, Regards, Dmitry

 

0 Kudos
Highlighted
Beginner
26 Views

Hi,

   My system is ubuntu14.04 .I can firefox on system.Thank you.

0 Kudos
Highlighted
Employee
26 Views

You need to install libxt6 package, on ubuntu simply run the following command:

> sudo apt-get install libxt6

0 Kudos
Highlighted
Beginner
26 Views

Hi,

I have installed libxt6 before.

wj@mcc21:~$ sudo apt-get install libxt6
[sudo] password for wj:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libxt6 is already the newest version.
libxt6 set to manually installed.
The following packages were automatically installed and are no longer required:
  libdbusmenu-glib4 libdbusmenu-gtk4 libstartup-notification0 libunwind8
  libx11-xcb1 libxcb-util0 linux-headers-3.19.0-25
  linux-headers-3.19.0-25-generic xul-ext-ubufox
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 139 not upgraded

0 Kudos
Highlighted
Employee
26 Views

Isn't your Ubuntu 32bit system? Can you launch 32bit version of amplxe-gui?

/opt/intel/vtune_amplifier_xe_2016.2.0.444464/bin32/amplxe-gui

Can you please provide the output of the following command:

> dpkg -l | grep libxt

0 Kudos
Highlighted
Beginner
26 Views

wj@mcc21:~$ dpkg -l | grep libxt
ii  libxt6:amd64                           1:1.1.4-1                                  amd64        X11 toolkit intrinsics library
ii  libxtables10                           1.4.21-1ubuntu1                            amd64        netfilter xtables library
ii  libxtst6:amd64                         2:1.2.2-1                                  amd64        X11 Testing -- Record extension library
ii  libxtst6:i386                          2:1.2.2-1                                  i386         X11 Testing -- Record extension library
wj@mcc21:~$ uname -a
Linux mcc21 3.19.0 #1 SMP Sun Apr 10 10:54:26 CST 2016 x86_64 x86_64 x86_64 GNU/Linux


 

0 Kudos
Highlighted
Employee
26 Views

Hm... very strange. Let check that libXt.so library is present and accessible:

> dpkg -L libxt6

should list you the files from this package. It should contain libXt.so.6.0.0 and libXt.so.6. Do ls -al for these files like:

> ls -al /usr/lib/x86_64-linux-gnu/libXt*

libXt.so.6 should sym link to libXt.so.6.0.0, make sure you have read permissions for both files.

0 Kudos
Highlighted
Beginner
26 Views

Hi,
   Thank you very much.It's amazing.After rebooting system,I can run amplxe-gui correctly .

0 Kudos