Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ingerman__eugene
Beginner
127 Views

amplxe-gui crashes under linux

I just installed Intel® Parallel Studio XE Professional Edition under OpenSuse leap 42.2 (which is based on Suse Enterprise 12).

However, gui front end is immediately crashing when I start it. Command line profiler works fine, but it's hard to analyse the results without gui front end. Same crash happens for gui front ends for other tools too.

Please help! Thank you.

gdb backtrace below:

>uname -a 
Linux laptop 4.4.36-8-default #1 SMP Fri Dec 9 16:18:38 UTC 2016 (3ec5648) x86_64 x86_64 x86_64 GNU/Linux

------------------------------------------------
> cat /etc/lsb-release 
LSB_VERSION="core-2.0-noarch:core-3.2-noarch:core-4.0-noarch:core-2.0-x86_64:core-3.2-x86_64:core-4.0-x86_64"
DISTRIB_ID="openSUSE Leap"
DISTRIB_RELEASE="42.2"
DISTRIB_CODENAME="42.2"
DISTRIB_DESCRIPTION="openSUSE Leap 42.2"

---------------------------------------------------------------------------------------

/opt/intel/vtune_amplifier_xe/bin64> gdb ./amplxe-gui
(gdb) r 
Starting program: /opt/intel/vtune_amplifier_xe_2017.1.0.486011/bin64/amplxe-gui  
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Detaching after fork from child process 25473.
Detaching after fork from child process 25474.
Detaching after fork from child process 25475.
Detaching after fork from child process 25476.
Detaching after fork from child process 25477.
[New Thread 0x7fffe5bef700 (LWP 25478)]
[New Thread 0x7fffe53ee700 (LWP 25479)]
[New Thread 0x7fffe478e700 (LWP 25480)]
[New Thread 0x7fffe3f8d700 (LWP 25481)]

Thread 1 "amplxe-gui" received signal SIGSEGV, Segmentation fault.
0x0000000000456cf0 in ?? ()


 

(gdb) bt 
#0  0x0000000000456cf0 in  ()
#1  0x00000000004a5dbf in  ()
#2  0x00007ffff341eef5 in wxEvtHandler::ProcessEvent(wxEvent&) () at /opt/intel/vtune_amplifier_xe_2017.1.0.486011/bin64/../lib64/libwx_gtk2-2.8.so.0
#3  0x00007ffff346cc18 in wxWindow::GTKProcessEvent(wxEvent&) const () at /opt/intel/vtune_amplifier_xe_2017.1.0.486011/bin64/../lib64/libwx_gtk2-2.8.so.0
#4  0x00007ffff346e4ce in  () at /opt/intel/vtune_amplifier_xe_2017.1.0.486011/bin64/../lib64/libwx_gtk2-2.8.so.0
#5  0x00007ffff01f8908 in g_closure_invoke () at /usr/lib64/libgobject-2.0.so.0
#6  0x00007ffff020a30d in  () at /usr/lib64/libgobject-2.0.so.0
#7  0x00007ffff02122a8 in g_signal_emit_valist () at /usr/lib64/libgobject-2.0.so.0
#8  0x00007ffff0212592 in g_signal_emit () at /usr/lib64/libgobject-2.0.so.0
#9  0x00007ffff14fc810 in IA__gtk_widget_realize (widget=0x7fe900) at gtkwidget.c:3561
#10 0x00007ffff14fc9f8 in IA__gtk_widget_map (widget=0x7fe900) at gtkwidget.c:3435
#11 0x00007ffff3469d59 in  () at /opt/intel/vtune_amplifier_xe_2017.1.0.486011/bin64/../lib64/libwx_gtk2-2.8.so.0
#12 0x00007ffff01f8aaf in  () at /usr/lib64/libgobject-2.0.so.0
#13 0x00007ffff0211918 in g_signal_emit_valist () at /usr/lib64/libgobject-2.0.so.0
#14 0x00007ffff0212592 in g_signal_emit () at /usr/lib64/libgobject-2.0.so.0
#15 0x00007ffff14fc9ce in IA__gtk_widget_map (widget=0x7fe870) at gtkwidget.c:3437
#16 0x00007ffff150cea2 in gtk_window_map (widget=0x81e310) at gtkwindow.c:4591
#17 0x00007ffff01f8b37 in  () at /usr/lib64/libgobject-2.0.so.0
#18 0x00007ffff0211918 in g_signal_emit_valist () at /usr/lib64/libgobject-2.0.so.0
#19 0x00007ffff0212592 in g_signal_emit () at /usr/lib64/libgobject-2.0.so.0
#20 0x00007ffff14fc9ce in IA__gtk_widget_map (widget=0x81e310) at gtkwidget.c:3437
#21 0x00007ffff150706e in gtk_window_show (widget=0x81e310) at gtkwindow.c:4555
#22 0x00007ffff01f8908 in g_closure_invoke () at /usr/lib64/libgobject-2.0.so.0
#23 0x00007ffff0209b37 in  () at /usr/lib64/libgobject-2.0.so.0
#24 0x00007ffff02122a8 in g_signal_emit_valist () at /usr/lib64/libgobject-2.0.so.0
#25 0x00007ffff0212592 in g_signal_emit () at /usr/lib64/libgobject-2.0.so.0
#26 0x00007ffff14fbf96 in IA__gtk_widget_show (widget=0x81e310) at gtkwidget.c:3243
#27 0x00007ffff347107a in wxWindow::Show(bool) () at /opt/intel/vtune_amplifier_xe_2017.1.0.486011/bin64/../lib64/libwx_gtk2-2.8.so.0
#28 0x00007ffff3466abd in wxTopLevelWindowGTK::Show(bool) () at /opt/intel/vtune_amplifier_xe_2017.1.0.486011/bin64/../lib64/libwx_gtk2-2.8.so.0
#29 0x00007ffff35f8592 in wxSplashScreen::wxSplashScreen(wxBitmap const&, long, int, wxWindow*, int, wxPoint const&, wxSize const&, long) ()
   at /opt/intel/vtune_amplifier_xe_2017.1.0.486011/bin64/../lib64/libwx_gtk2-2.8.so.0
#30 0x00000000004a9967 in  ()
#31 0x00007ffff33cb9ce in wxEntry(int&, char**) () at /opt/intel/vtune_amplifier_xe_2017.1.0.486011/bin64/../lib64/libwx_gtk2-2.8.so.0
#32 0x00000000004a4d1d in  ()
#33 0x00007ffff1eb56e5 in __libc_start_main (main=
   0x4a4ce0, argc=1, argv=0x7fffffffdb38, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffffffdb28) at libc-start.c:289
#34 0x0000000000427d69 in  ()
#35 0x00007fffffffdb28 in  ()
#36 0x000000000000001c in  ()
#37 0x0000000000000001 in  ()
#38 0x00007fffffffe01c in  ()
#39 0x0000000000000000 in  ()
(gdb) 

 

0 Kudos
4 Replies
Dmitry_K_Intel1
Employee
127 Views

Hi Eugene,
To help you I need answers for some question below...

Do you have default or custom installation of openSUSE 42.2?

Do you have any gtk application(like gedit, calculator(galculator), Firefox, ... ) working on the system?

Could you check what GTK version/components installed on the system?
>pkg-config --list-all | grep gtk

What version of gcc do you have on the system installed (by default)?
>gcc -v

 

ingerman__eugene
Beginner
127 Views

Hello Dmitry,

I have default installation of openSUSE 42.2 (distribution upgrade from previous version).

gedit, galculator and firefox run correctly.

pkg-config --list-all | grep gtk
gtk-doc                          gtk-doc - API documentation generator
gtk+-x11-3.0                     GTK+ - GTK+ Graphical UI Library
gtk-sharp-2.0                    Gtk - Gtk
gtk+-broadway-3.0                GTK+ - GTK+ Graphical UI Library
gtkmm-2.4                        gtkmm - C++ binding for the GTK+ toolkit
gtk+-unix-print-2.0              GTK+ - GTK+ Unix print support
gtkmm-3.0                        gtkmm - C++ binding for the GTK+ toolkit
gtk+-unix-print-3.0              GTK+ - GTK+ Unix print support
colord-gtk                       colord-gtk - colord-gtk is GTK integration for libcolord
gtk-dotnet-2.0                   Gtk.DotNet - .NET Extensions for Gtk
gtk+-2.0                         GTK+ - GTK+ Graphical UI Library (x11 target)
libcanberra-gtk3                 libcanberra-gtk3 - Gtk3 Event Sound API
gtk+-3.0                         GTK+ - GTK+ Graphical UI Library
libcanberra-gtk                  libcanberra-gtk - Gtk Event Sound API
gtk+-x11-2.0                     GTK+ - GTK+ Graphical UI Library (x11 target)


gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib64/gcc/x86_64-suse-linux/4.8/lto-wrapper
Target: x86_64-suse-linux
Configured with: ../configure --prefix=/usr --infodir=/usr/share/info --mandir=/usr/share/man --libdir=/usr/lib64 --libexecdir=/usr/lib64 --enable-languages=c,c++,o
bjc,fortran,obj-c++,java,ada --enable-checking=release --with-gxx-include-dir=/usr/include/c++/4.8 --enable-ssp --disable-libssp --disable-plugin --with-bugurl=http
://bugs.opensuse.org/ --with-pkgversion='SUSE Linux' --disable-libgcj --disable-libmudflap --with-slibdir=/lib64 --with-system-zlib --enable-__cxa_atexit --enable-l
ibstdcxx-allocator=new --disable-libstdcxx-pch --enable-version-specific-runtime-libs --enable-linker-build-id --enable-linux-futex --program-suffix=-4.8 --without-
system-libunwind --with-arch-32=i586 --with-tune=generic --build=x86_64-suse-linux --host=x86_64-suse-linux
Thread model: posix
gcc version 4.8.5 (SUSE Linux)

 

Thank you.

nico_r_
Beginner
127 Views

Hello,

Very similar error here (Opensuse leap 42.2, 4.4.62-18.6-default, vtune_amplifier_xe_2017.4.0.518798).

Just started my trial, CL tools are working but no Gui. Any ideas?

Dmitry_K_Intel1
Employee
127 Views

Hello, could you post output of the following commands from VTune directories?

from <VTune_install_dir>/bin64$
ldd amplxe-gui

and from <VTune_install_dir>/lib64$
ldd libxul.so

Thanks,
Dmitry.
 

Reply