Analyzers
Talk to fellow users of Intel Analyzer tools (Intel VTune™ Profiler, Intel Advisor)
5021 Discussions

error launching vtune-gui after installation.

qgao
Employee
1,623 Views

Hello, 

I have the following error message after install Intel oneAPI Base toolkit. The installation is done by current user (nonroot user). 

 

Fontconfig warning: "/etc/fonts/fonts.conf", line 86: unknown element "blank"
[104618:0622/123508.008581:ERROR:browser_main_loop.cc(1409)] Unable to open X display.

 

Does anyone have any idea on this error? 

 

 

0 Kudos
1 Solution
JaideepK_Intel
Moderator
1,600 Views

Hi,

 

Thank you for posting in Intel Communities.

I assume you are trying to access vtune-gui from a remote server because of that you are getting this error.

JaideepK_Intel_0-1655962871076.png

Work around(Port Forwarding)

If you have a web browser on your host machine, you can follow the below process.

Step1:

To connect to a remote server, we use ssh user_name@<IP_address of that server>

Since we need to port forward our localhost to the remote server, we use the below command.

ssh -L 127.0.0.1:<port_number>:127.0.0.1:<port_number> user_name@IP

 

example: ssh -L 127.0.0.1:7070:127.0.0.1:7070 user_name@IP (Here I am forwarding my local host to port 7070)

 

Step2:

Now I need to run vtune-backend with web port 7070.

 

example: vtune-backend --web-port 7070 --enable-server-profiling

 

After running the above command, you can see 2links are generated. Copy any one of them into your browser.

JaideepK_Intel_1-1655962253566.png

JaideepK_Intel_3-1655962306899.png

JaideepK_Intel_4-1655962452206.png

 

If this resolves your issue, make sure to accept this as a solution. This would help others with similar issue.

 

Thanks,

Jaideep

 

 

View solution in original post

0 Kudos
4 Replies
JaideepK_Intel
Moderator
1,601 Views

Hi,

 

Thank you for posting in Intel Communities.

I assume you are trying to access vtune-gui from a remote server because of that you are getting this error.

JaideepK_Intel_0-1655962871076.png

Work around(Port Forwarding)

If you have a web browser on your host machine, you can follow the below process.

Step1:

To connect to a remote server, we use ssh user_name@<IP_address of that server>

Since we need to port forward our localhost to the remote server, we use the below command.

ssh -L 127.0.0.1:<port_number>:127.0.0.1:<port_number> user_name@IP

 

example: ssh -L 127.0.0.1:7070:127.0.0.1:7070 user_name@IP (Here I am forwarding my local host to port 7070)

 

Step2:

Now I need to run vtune-backend with web port 7070.

 

example: vtune-backend --web-port 7070 --enable-server-profiling

 

After running the above command, you can see 2links are generated. Copy any one of them into your browser.

JaideepK_Intel_1-1655962253566.png

JaideepK_Intel_3-1655962306899.png

JaideepK_Intel_4-1655962452206.png

 

If this resolves your issue, make sure to accept this as a solution. This would help others with similar issue.

 

Thanks,

Jaideep

 

 

0 Kudos
qgao
Employee
1,558 Views

Thank Jaideep. It helps a lot to use the profiler server as you stated to get a gui experience. I have a follow up question. When I try to deploy a VTune Agent onto the remote Linux server, I keep getting the following confusing errors: 

qgao_0-1656374062394.png

 

The vtune runs on a linux server and I am trying to deploy an agent on that server. What does it have to do with the above error? 

 

 

0 Kudos
JaideepK_Intel
Moderator
1,538 Views

Hi,

 

Thanks for accepting our solution. From the above attachment, I can see Vtune can't run on unsupported operating systems. Maybe you are trying to profile on an unsupported target. We can run the Vtune profiler on Windows and on Linux. Please go through the below attachment.

Link :Intel® VTune™ Profiler System Requirements

JaideepK_Intel_0-1656417061681.png

 

Thanks,

Jaideep

 

0 Kudos
JaideepK_Intel
Moderator
1,498 Views

Hi,

 

Thanks for accepting our solution. If you need any additional information, please post a new question as this thread will no longer be monitored by Intel.

 

Thanks,

Jaideep

 

0 Kudos
Reply