Community
cancel
Showing results for 
Search instead for 
Did you mean: 
vmjb
Beginner
86 Views

how do i reset the source binary for a module?

The software I'm trying to analyze can be built in two ways, I'll call them A and B. When I run a VTune sampling collection on build A, it gives me the usual breakdown of where in that software the clockticks were spent. I now want to drill down into one particular module, so when it asks me where the binary is stored, I point it to the proper path.

Now, when I run build B and try to drill down to the same module, it automatically brings up the function names derived from the binary from A.

How do I tell VTune to look at a different path for a module with name for which it already thinks it has the proper path?

The only differences between builds A and B are that B has more performance profiling code in it, so A is a leaner, supposedly faster, version. The set of A's functions should be a subset of B's, but can I be certain that they're placed at the same memory addresses and, hence, map to the same function names? I would think the answer is no, and so I'd like to redirect the module to the appropriate binary.

As it is now, the only way I can do this is to uninstall VTune from my RHEL3 system, then hunt down every single directory it created and delete those, re-install, then have it re-prompt me for the module binary path again.

Is there an easy way to do this? The GUI and Help haven't yielded anything substantial.
0 Kudos
1 Reply
David_A_Intel1
Employee
86 Views

So, two suggestions for everyone:
First, if you want to do comparisons of the same app built in different ways, make sure the binaries have unique names.
Second, since the UI is lacking from 3.0, you can remove the /tmp/vtune_/ISM directory to reset the symbol information.
Basically, the VTune analyzer is trying to be smart and recognize that it has already processed the symbols for module XYZ. Unfortunately, something causes it to not recognize that the module dir1/XYZ is not the same as dir2/XYZ. This is a known issue and may be resolved in a future release.
Something else you might try is to use Projects in vtlec to separate the modules and then specify a search path in the Windows -> Preferences (menu): VTune Performance Analyzer -> Directories option page. I don't know if it will help, but it might! :-}
Regards,
Reply