Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Max_C_
Beginner
199 Views

met some problem using advanced-hotspots

Hi all,

We met some problem using advanced-hotspots.

amplxe-cl -collect advanced-hotspots -r max_test_2_11 -duration 30 --target-pid 6859
 amplxe: Error: Cannot enable Hardware Event-based Sampling: problem with the driver (sep*/sepdrv*). Check that the driver is running and the driver group is in the current user group list. See "Building and Managing the Sampling Driver" help topic for further details.


Maybe some driver is missing. We are OK without Hardware Event-based Sampling.

I tried to use amplxe-cl -collect hotspots. Our lab restarted.

Is there something wrong?

Here is out put during installation:

Step 1 of 6 | Prerequisites > Missing Optional Prerequisite(S)
 --------------------------------------------------------------------------------
 There are one or more optional unresolved issues. It is highly recommended to
 resolve them all before you continue the installation. You can fix them without
 exiting from the installation and re-check. Or you can quit from the
 installation, fix them and run the installation again.
 --------------------------------------------------------------------------------
 Missing optional prerequisites
 -- Driver build options are incomplete. Drivers cannot be built.
 -- Cannot detect gtk library
 --------------------------------------------------------------------------------
 1. Skip missing optional prerequisites [default]
 2. Show the detailed info about issue(S)
 3. Re-check the prerequisites

Installing drivers. It may take several minutes... done
 --------------------------------------------------------------------------------
 Error while building sampling driver, see /tmp/amplifier_sampling_build_25.03.15.06.41.00.log for details
 --------------------------------------------------------------------------------
 Press "Enter" key to continue

Error while building sampling driver, see /tmp/amplifier_sampling_build_26.03.15.00.11.05.log for details

ERROR: "none" either does not exist or is not a directory!

<qhp15-s00c01h0:root>/opt/intel/vtune_amplifier_xe_2015.2.0.393444/sepdk/src:
 # ./insmod-sep3 -q
 pax driver is not loaded.
 sep3_15 driver is not loaded.
 vtsspp driver is not loaded.

 

0 Kudos
8 Replies
David_A_Intel1
Employee
199 Views

You probably don't have the kernel sources/headers installed.

Change directory into <installdir>/sepdk/src and, as root, execute ./build-driver.  Press [Enter] to accept the default for all prompts.  Is the driver successfully built?  If not, resolve the error messages and try again.  If so, execute './insmod-sep3 -r' and see if the driver is installed.

BTW, what OS are you running?

Max_C_
Beginner
199 Views

Hi MrAnderson,

I am running Vtune under Red Hat Enterprise Linux Server release 5.8 (Tikanga)

# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 5.8 (Tikanga)

We simplify the system and we don't have gcc in our system.

I change directory into <installdir>/sepdk/src and, as root, execute ./build-driver. Output is:

Error while building sampling driver, see /tmp/amplifier_sampling_build_26.03.15.00.11.05.log for details

ERROR: "none" either does not exist or is not a directory!

We don't have gcc in our system, so I think we can't build driver in outsystem. Can I use Vtune without Hardware Event-based Sampling?

BTW: Command amplxe-cl -collect hotspots is OK, but our lab restarted after Vtune attach on our process.

Command amplxe-cl -collect advanced-hotspots is failed.

Thanks

Max

 

 

David_A_Intel1
Employee
199 Views

Hi Max:

Correct, without a compiler, you can't build the driver.  So, where are you building the application?  Is this an embedded application?

Yes, you can still profile using the software-based analysis types: basic hotspots, concurrency, and locks and waits.

When you say "our lab", I assume you mean your application?  Or, do you mean the system reboots?  If there is a problem profiling with "attach", can you try configuring VTune Amplifier to "launch" the application?  If not, can you attempt to attach to another application on the system, such as vi or something?

Max_C_
Beginner
199 Views

Hi MrAnderson,

Thanks for your replying. Here is the answer to your question.

1. Where are you building the application?  Is this an embedded application?

We have a build machine to build our binary. Our application is not embedded.

2. you can still profile using the software-based analysis types: basic hotspots, concurrency, and locks and waits

We can't use software-based analysis. When we try to attach to the process, the system/process restarted(We have different product, for some product,process restart only; for some product,system restart).

3. When you say "our lab", I assume you mean your application?Or, do you mean the system reboots?

"out lab" means the system. We have different product, for some product,process restart only; for some product,system restart.

Our product have a daemon process, It will cause the process/system restart I guess.

There is a heart-beat like sync between our product and the daemon peocess. But when I try to attach the software, maybe(just I guess) Vtune block up the sync. The daemon process will restart the process/system.

Will Vtune hold some message while using "software-based analysis"? Or can you give me some information about the mechanism of how Vtune attach one process.

4. If there is a problem profiling with "attach", can you try configuring VTune Amplifier to "launch" the application? 

We can't launch the application. This maybe a little complex. We control memory by ourselves, not Linux. We ask a chunk of memory from system, then we control the memory by ourselves. So every time we start an application, we force the application to start at a specified place. So we can't launch the application. BTW: can Vtune launch an application with parameters?

5. If not, can you attempt to attach to another application on the system, such as vi or something?

We can attach to VI and even some of our product.

I guess maybe some of our product have a tight connect to system and cause that we can't use "software-based analysis"?

 

Thanks

Max

David_A_Intel1
Employee
199 Views

Okay, a few thoughts.  First, software-based collection injects code into your application and can effect execution.  Is there any way to disable the "heart-beat" check in your app?  That will sometimes allow the profiling to work.

Second, yes, you can specify command-line parameters in the project configuration window.

Finally, another option is to build the driver on a system with the compiler and put the driver on the system-under-test.  However, it must be the same exact configuration (kernel, gcc-lib, etc.).

bsv__venki
Beginner
199 Views

Hi,

 

Step 2 of 7 | Intel® Software Improvement Program
--------------------------------------------------------------------------------
To improve our software and customer experience, Intel would like to collect
technical information about your software installation and runtime status (such
as installation metrics, license/support types, software SKU/serial, counters,
flags, and timestamps) and development environment (such as operating system,
CPU architecture, last 4-digits of the MAC address and other Intel products
installed). (“Information”).

Information collected under this notice may be retained by Intel indefinitely
but it will not be shared outside of Intel or its wholly-owned subsidiaries.

You can revoke your consent at any time by choosing “Improvement Program
Options" in the "Settings" tab of the Intel® Software Manager and selecting the
"I do NOT consent to the collection of my Information” option.

    Learn more about the Intel® Software Improvement Program
    http://software.intel.com/en-us/articles/software-improvement-program

--------------------------------------------------------------------------------
1. I consent to the collection of my Information
2. I do NOT consent to the collection of my Information

b. Back to the previous menu
q. Quit
--------------------------------------------------------------------------------
Please type a selection: 2
--------------------------------------------------------------------------------
Checking the prerequisites. It can take several minutes. Please wait...
--------------------------------------------------------------------------------

 

2018 version 3 blocks on my system during instalation , what might be the reason. ?

3.10.0-229.20.1.el7.x86_64 #1 SMP Tue Nov 3 19:10:07 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Thanks,

Venkaesh

bsv__venki
Beginner
199 Views

Hi,

 

Step 2 of 7 | Intel® Software Improvement Program
--------------------------------------------------------------------------------
To improve our software and customer experience, Intel would like to collect
technical information about your software installation and runtime status (such
as installation metrics, license/support types, software SKU/serial, counters,
flags, and timestamps) and development environment (such as operating system,
CPU architecture, last 4-digits of the MAC address and other Intel products
installed). (“Information”).

Information collected under this notice may be retained by Intel indefinitely
but it will not be shared outside of Intel or its wholly-owned subsidiaries.

You can revoke your consent at any time by choosing “Improvement Program
Options" in the "Settings" tab of the Intel® Software Manager and selecting the
"I do NOT consent to the collection of my Information” option.

    Learn more about the Intel® Software Improvement Program
    http://software.intel.com/en-us/articles/software-improvement-program

--------------------------------------------------------------------------------
1. I consent to the collection of my Information
2. I do NOT consent to the collection of my Information

b. Back to the previous menu
q. Quit
--------------------------------------------------------------------------------
Please type a selection: 2
--------------------------------------------------------------------------------
Checking the prerequisites. It can take several minutes. Please wait...
--------------------------------------------------------------------------------

 

2018 version 3 blocks on my system during instalation , what might be the reason. ?

3.10.0-229.20.1.el7.x86_64 #1 SMP Tue Nov 3 19:10:07 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Thanks,

Venkaesh

Eugene_C_Intel
Employee
199 Views

bsv, venki wrote:

2018 version 3 blocks on my system during instalation , what might be the reason. ?

3.10.0-229.20.1.el7.x86_64 #1 SMP Tue Nov 3 19:10:07 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Hi Venkaesh,
Could you please provide the log file of unsuccessful installation? It will help to find the reason of this issue. Log file is located in '/tmp' or $TMPDIR directory and its name starts from 'intel.pset'; this file doesn't contain confidential information.

 

Reply