Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
42 Views

ptrace system call rejected

Hi,

so i'm a total newbie to the VTune Amplifier XE 2011, I just installed it and was trying to run a basic analysis of the tachyon example provided in "Getting started tutorial". I did everything as I was supposed to do but unfortunately there's a problem that reads:

Error: Failed to start profiling because attaching to the analysis target using ptrace system call was rejected.
Error: Failed to attach to the process with the specified PID. Specify another PID and try attaching again.

I see two possibilities for that:
1. Im forced to run VTune on Debian which is not ofically supported.
2. I installed VTune as a regular user (not a root).

Might these be the reasons? Or is it anytghing else that im missing? I could try to beg my admin to install this in the root-mode but there's no way to change the linux distro.

Any solutions/suggestions would be kindly appreciated.
Regards,
Kazik
0 Kudos
5 Replies
Highlighted
42 Views

Hello,
Attaching to a process is only available on Windows at the moment. I will check and confirm once again if we have alternate ways for you to achieve what you want to do.

Thanks,
Krishna
0 Kudos
Highlighted
Beginner
42 Views

Hi Krishna,

truly speaking i just wanted to start with this basic stuff that Intel provides in the tutorial but apparently the VML didn't even manage to launch the "tachyon" application showing this very error mesage I posted last time. I also tried to first run a process (externally so to speak, independently of the VML) and then explicitly type PID in VML project properties to initiate the analysis but also didn't work.

Any further help appreciated,
Cheers,
K.
0 Kudos
Highlighted
Employee
42 Views

What version of Debian is the system running?

The error is possibly due to a permissions or security setting.
Things to try:

1. Can you run the tachyon example outside of Amplifier XE?
2. If yes, does running 'strace' on the tachyon example succeed?


Mark
0 Kudos
Highlighted
Beginner
42 Views

Hi Mark,

it's Debian GNU/Linux 5.0.8 (lenny).

1) Yes, both tachyon_analyze_locks and tachyon_find_hotspots seem to work (i can see that they render a picture with some spheres and they normally quit without crashing)
2) Im not an expert in reading strace logs, i attach a file stracelog.log with what strace has just generated so you can tell me.

Any ideas are kindly welcome.
0 Kudos
Highlighted
Beginner
42 Views

Anyone has an idea?
0 Kudos