Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
4747 Discussions

unable to connect to intel vtune server on Devcloud

tanzl_ustc
Beginner
389 Views

Dear Intel engineers:

Hello! Early this day I tried to use vtune on Devcloud to analyze the performance of my DPC++ code. I have followed the instructions given by https://www.intel.com/content/www/us/en/develop/documentation/vtune-cookbook/top/configuration-recip... .However the link given by terminal can not be reached.The figure below has shown the circumstance.

tanzl_ustc_0-1651512514457.png

I have tried several times with the link provided by terminal but the ciucumstance still remained the same(I have tried the link with Chrome and Safari in newest version,but the link was still unreachable).I was wondering if you could tell me some possible solutions to this problem,thank you!

Best&Regards

Zelin Tan

0 Kudos
6 Replies
AlekhyaV_Intel
Moderator
346 Views

Hi Zelin,

 

Thank you for posting in Intel Communities. We could reproduce your issue. SSH port forwarding would resolve your issue. Please follow the below steps after you connect to DevCloud through VSCode.

 

1) Please keep your VSCode open & stay connected to devcloud.

 

2) Open a new Cygwin/Mobaxterm terminal.

 

3) Log into the DevCloud node again, this time with SSH Port forwarding enabled:

 

 

ssh -L 127.0.0.1:55001:127.0.0.1:55001 devcloud

 

 

 

4) Establish an SSH connection from the login node to the compute node with one more SSH tunnel:

 

 

ssh -L 127.0.0.1:55001:127.0.0.1:55001 s000-n000

 

 

Replace s000-n000 with your compute node you got in VSCode.

 

5) Start VTune server on the compute node:

 

 

vtune-backend --web-port=55001 --enable-server-profiling

 

 

Use the  --web-port=PORT command-line option to run VTune server on a specific port. While port forwarding, a specific port i.e. "55001" was given along with the IP address.  

 

6) Open the VTune GUI. Use your web browser to open the URL displayed by the VTune server.

 

If this helps, please make sure to accept as a solution so that it helps other users with similar issue. Please let us know if the issue still persists.

 

Thanks & Regards,

Alekhya

 

 

 

 

 

tanzl_ustc
Beginner
313 Views

Hi,thanks for your reply.I am sorry that the method did not solve my problem.I did every step you mentioned above on my laptop(Macbook M1),but the link still could not be reached.I am very pleased to keep in touch with you on this issue.Sincere gratitude!

AlekhyaV_Intel
Moderator
297 Views

Hi Zelin,


Could you please check whether the Port number you've given is free?

Did you get any error while trying the above method? If yes, please attach the screenshot.

We will connect with you through private message/email to get your DevCloud config file


Regards,

Alekhya


AlekhyaV_Intel
Moderator
259 Views

Hi Zelin,

 

Could you please give us an update regarding this issue? We need your DevCloud config file & the error screenshot to debug your issue further.

 

As you mentioned that you're using MAC machine, please follow the below steps and let us know if the issue still persists. For MAC machines, a slight modification must be made. Please make the below modification to the Proxy Command:

  • ProxyCommand /usr/bin/nc -X 5 -x PROXY_HOSTNAME:PORT %h %p
  • Kindly Replace "PROXY_HOSTNAME:PORT" from the correct proxy.

 

Regards,

Alekhya

 

AlekhyaV_Intel
Moderator
230 Views

Hi,


Could you please give us an update regarding this issue?


Regards,

Alekhya


AlekhyaV_Intel
Moderator
208 Views

Hi Zelin,


We assume that your issue is resolved. If you need any further assistance, please post a new question as this thread will no longer be monitored by Intel.


Regards,

Alekhya


Reply