Community
cancel
Showing results for 
Search instead for 
Did you mean: 
odedf
Beginner
97 Views

vtlec crashes on big projects

Hi,
I am able to run vtl (vtune 8.0) in batch mode and then read the results from vtlec, on very small programs. When I try to do the same on a "real" project, vtlec crashes. Is it a known problem. Will I get the same results if I would try to do it in the windows version of the gui?
related question:
When I run vtl and then open the results in vtlec I see all the processes and not only the process a sampled. I have tried to use the -moi flag but it did not seem to affect the results. The command line I use is:
/opt/intel/vtune/bin/vtl project /tmp/Project1/.vtproject.data/Project1.vpj activity -c sampling -appexec -moiexec run
0 Kudos
2 Replies
David_A_Intel1
Employee
97 Views

Well, first, don't combine the 'project' and 'activity' commands to vtl. :smileysad: This probably shouldn't even be allowed and you may have identified a bug, but it is definitely not safe to do it.

Instead, as I said in the other post, use the 'vtl activity' to collect the data and then 'vtl pack' to export the data. Then, in vtlec, use the File -> Import menu item to load the data.

Since sampling is a system-wide data collection mechanism, you will always be able to see all the processes running during the collection. Sometimes users what to see this info (e.g., inter-process communication, driver developers, etc.). To limit your view, specify your default view to open for Sampling as Processes in the Preferences (See Window menu, then expand VTune Performance Analyzer and select Sampling). Now, when the results are opened, select your process and press the Threads (if your app is multi-threaded, for example)or Modules buttons, or double-click to open the Threads view.

97 Views

Sounds like you're running out of system resources of some kind (processes, filesystem space, something...) when running a bigger application on vtlec.

If you view the "real" application using the vtl command, does it lock up too?

To test, try these:

$ vtl view | more

and

$ vtl view -gui

If one or both of these don't fail, at least you'll have a workaround for now.

Note that the -moi flag is not a guarantee that you will see the module you requested when you run sampling: for example, what if the module doesn't even run? The -moi has a more solid meaning with the callgraph way of operating. To learn more about this:

$ man sampling

$ man callgraph

In the command line example that you list below, it might make more sense to use various vtl view commands where you list the -mn (module name) for the modules you are looking at. The "man sampling" command will give you more on that, with the "view" options of vtl.

cheers

jdg

Reply