Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Bierman__Keith
Beginner
135 Views

vtune amplifier 2019 update5 platform install issue on Ubuntu 19.04

Base installation worked fine, collector worked fine (although an unmet/unadvertised required "dstat" package had to be manually installed). But "server" appears to have a bit of a showstopper.
 

superMkhb:/opt/intel/vtune_amplifier/vpp/server>sudo apt-add-repository ppa:webupd8team/java
[sudo] password for khb: 
 The Oracle JDK License has changed for releases starting April 16, 2019.

The new Oracle Technology Network License Agreement for Oracle Java SE is substantially different from prior Oracle JDK licenses. The new license permits certain uses, such as personal use and development use, at no cost -- but other uses authorized under prior Oracle JDK licenses may no longer be available. Please review the terms carefully before downloading and using this product. An FAQ is available here: https://www.oracle.com/technetwork/java/javase/overview/oracle-jdk-faqs.html

Oracle Java downloads now require logging in to an Oracle account to download Java updates, like the latest Oracle Java 8u211 / Java SE 8u212. Because of this I cannot update the PPA with the latest Java (and the old links were broken by Oracle).

For this reason, THIS PPA IS DISCONTINUED (unless I find some way around this limitation).....
sudo apt-get install oracle-java8-installer
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package oracle-java8-installer is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or....

 

Aside from downgrading the OS, or finding another system for this experiment is there an easy path forward? Is there some reason why we're sticking with java8?  As this u19 system is a KVM host for several experimental VMs, I did briefly try to install under ubuntu 16 ... but the base install (the step directly after tar xvzf *.tar.gz) fails with "unsupported CPU" ... doubtless because when I set up the VM I didn't specially configure it for vtune ...

0 Kudos
1 Reply
Asaf_Y_Intel
Employee
135 Views

Hi Keith,

Java is not required for running the VPP server. Looking at your other posts, it looks like you were able to successfully configure the VPP server and visualize VPP collected data.

Thanks,

Asaf

 

Reply