Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
4554 Discussions

vtune amplifier memory analysis causing hard reboot on linux

emmanuel1
Novice
309 Views

Hello,

I'm using vtune_amplifier_xe_2017.3.0.510739

on CentOS 7.6.1810

with processor Intel(R) Core(TM) i7-4790 CPU @ 3.60GHz

on a simple test C++ program int main() { int s = 0; for(int i = 0; i < 1000; i++) { s += i; } printf("%d\n", s); }

I launch amplxe-gui with environment variable AMPLXE_MORE_PIN_OPTION='-ifeellucky', and nmi_watchdog disabled.

Then, a few seconds after launching the Memory Access Analysis tool, the screen turns black and the computer reboots.

Any idea?

 

Labels (1)
0 Kudos
1 Solution
ArunJ_Intel
Moderator
268 Views

Hey emmanuel1,


Could you please try with vtune profiler 2020 Update 3. This version is available in the download link in my previous response.



Thanks

Arun


View solution in original post

7 Replies
ArunJ_Intel
Moderator
294 Views

Hey emmanuel1,

 

The version of vtune you use seems to be old/outdated, which might be causing the issue. Could you please try downloading the latest vtune version and try your experiment again. You can download latest version of vtune from the below Link for free.

Intel VTune Profiler

 

Please let us know if you are facing any issues with the latest version

 

Thanks

Arun Jose

 

emmanuel1
Novice
277 Views

Hello & thanks for your suggestion.

We updated and tried vtune_amplifier_xe_2017.6.0.554757

The result is the same.

Perhaps that is not the latest version?

 

Kirill_U_Intel
Employee
271 Views

Hi.

The last version is 2020 update 3. You have 2017 major version, I think it was 3 years ago

Kirill

ArunJ_Intel
Moderator
269 Views

Hey emmanuel1,


Could you please try with vtune profiler 2020 Update 3. This version is available in the download link in my previous response.



Thanks

Arun


View solution in original post

Kirill_U_Intel
Employee
266 Views
emmanuel1
Novice
256 Views

Thanks @ArunJ_Intel @Kirill_U_Intel .

Upgrading to vtune profiler 2020 update 3 actually solves the issue.

 

ArunJ_Intel
Moderator
249 Views

Glad to know your issue has been resolved. We wouldn't be monitoring this thread any further. Please feel free to raise a new thread in case of any further issues.


Thanks

Arun


Reply