Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)

vtune problem on ubuntu

AronRoland
Beginner
692 Views

Hi Everybody,

i am using following Ubuntu version;

 

Distributor ID: Ubuntu
Description:    Ubuntu 21.04
Release:        21.04
Codename:       hirsute

... and I have updated today 9/12/21 the oneApi as well as Vtune ...

 

Issue:

 

vtune: Error: [Instrumentation Engine]: Source/pin/injector_u/loadercommands.cpp: NotifyOnMiniloaderFailure: 689: Injector: caught unexpected signal 11 while running miniloader on file /usr/bin/dash  
vtune: Error: Result path `/home/aron/git/SweTools/regtests/worms2/vtune.T490s/vtune.T490s.vtune' does not exist.

Vtune command:

 

mpirun -n 4 vtune -quiet -collect hotspots -trace-mpi -result-dir vtune swetools

 

I have attached the log output of the self-checker ...

 

Thanks in advance ...

 

Aron

0 Kudos
6 Replies
JananiC_Intel
Moderator
669 Views

Hi,


Thanks for posting in Intel forums.


In your command you have mentioned swetools and we are not sure if that is executable or result directory name.So we tried in Ubuntu 20.04 with a matrix sample with the below command and were able to run successfully.


"mpirun -n 16 -ppn 4 -l vtune -collect hotspots -k sampling-mode=sw -trace-mpi -result-dir my_result -- ./matrix_mul_dpc"


This command is from the documentation(https://software.intel.com/content/www/us/en/develop/documentation/vtune-help/top/analyze-performanc... can refer the above link for mpi analysis.


Try this and let us know.


Regards,

Janani Chandran


AronRoland
Beginner
656 Views

Hi Janani,

 

so yes "swetools" is the exe that I want to profile. Now I have invoked vtune with ...

 

mpirun -n 4 -ppn 4 -l vtune -collect hotspots -k sampling-mode=sw -trace-mpi -result-dir my_result swetools

 

and the error is quite similar.

 

[0] vtune: Error: [Instrumentation Engine]: Source/pin/injector_u/loadercommands.cpp: NotifyOnMiniloaderFailure: 689: Injector: caught unexpected signal 11 while running miniloader on file /usr/bin/dash  
[0] vtune: Collection failed.
[0] vtune: Internal Error

I like to add that I have been profiling this code for the last 5 years with parallel studio with no issue.

 

I like to thank u very much for your prompt reply and hope that we can sort out this issue.

 

Cheers

 

Aron

JananiC_Intel
Moderator
604 Views

Hi,


Could you try the exact command given below.


mpirun -n 16 -ppn 4 -l vtune -collect hotspots -k sampling-mode=hw -trace-mpi -result-dir my_result -- ./swetools


We could see a minor change in your previous command and in the above command we have mentioned hardware sampling so try the same and let us know.


After trying this if you get any error, then share the appropriate error log and screenshots.


Regards,

Janani Chandran


JananiC_Intel
Moderator
574 Views

Hi,


Is your issue resolved? Do you have any update?


Regards,

Janani Chandran


JananiC_Intel
Moderator
504 Views

Hi,


I assume that your issue is resolved. If you need any additional information, please post a new question as this thread will no longer be monitored by Intel.


Regards,

Janani Chandran


Vladimir_R_Intel
Employee
443 Views

Hi,

The issue is fixed in VTune version 2021.8.0.

 

BR,

Vladimir Rodionov

Reply