Community
cancel
Showing results for 
Search instead for 
Did you mean: 
wayne-wooten
Beginner
65 Views

vtuneBeta3.0 With 2.6.6 kernel

I would REALLY love to have vTune3
work under FedoraCore2. I have downloaded
the course to the 2.6.6 kernel, installed
the patches from the 2.6.x driver kit
(they are badly out of date by the way,
and I had to modify the patch somewhat).

I then got the kernel to work, but I
cannot get the driver to build. First
off it is looking for ksyms.c in
/usr/src/linux-2.6.x/kernel and it is no
longer there it has been moved.

After I pointed it at the correct location,
it builds a vtune_drv.o, but when I try
to insmod that, it complains:

-1 Invalid module format

and dmesg reports

No module found in object.

So I am stuck, very close, but stuck.
I assume the module format has changed
since this module kit was released almost
a year ago. Can someone update this kit
or give me a hint to where I should look
to make the changes myself?

Thanks!
--Wayne Wooten
Pixar Animation Studios
0 Kudos
1 Reply
65 Views

Hey Wayne,
We're checking this out on the engineering side now: stay tuned.
cheers
jdg
Reply