Application Acceleration With FPGAs
Programmable Acceleration Cards (PACs), DCP, FPGA AI Suite, Software Stack, and Reference Designs
479 Discussions

N6000-PL is not showing up in 'lspci'

Beginner_in_FPGA
New Contributor I
1,521 Views

Hey, 

I have with me the N6000-PL card which was provided by Intel. And am trying to test the card as is by connecting to a Dell PowerEdge R520 Server. This server is populated by a single CPU hence the card is connected to an x16 slot but the bandwidth available is x8, the server also doesn't support PCIe Bifurcation. In the Command prompt upon using lspci the card doesn't show up anywhere. And The power LED is green but the rest two LEDs "STS" and "ALM" are Red.

1) Is this common until I flash the MAX10 and Agilex FPGA with the BMC and OFS respectively?
2) Does this mean that the Board already has images preinstalled or is it a clean slate?

Thank you,
Best Regards.

12 Replies
Beginner_in_FPGA
New Contributor I
1,415 Views

Hey, 

I solved the "lspci" issue with a proper power boot sequence. 

But now after checking in lspci and rebooting the system the error - 
"pci 0000:01:00.0: AER: Error of this Agent is reported first"
Keeps popping up bootup. 

Any idea as to what might be the issue?

Thank you,
Best Regards.

khtan
Employee
1,372 Views

Hi, 

I'm Kian and will also be assisting you in this case. 

 

I suspect the card needs to be programmed first . Have you done any programming to the card ?

Also I was looking up on the AER error and some mentioned about disabling the pcie power management might help (pcie_aspm=off) to resolve the issue AER: Error of this Agent is reported first

 

Quote"

This may be due to PCIe Active State Power Management that is transitioning the link to a lower power state and maybe causing the device to trigger these errors.
You could add this to "/etc/default/grub"

Code:
pcie_aspm=off

And

Code:
sudo update-grub

"

 

Thanks

Regards 

Kian

Beginner_in_FPGA
New Contributor I
1,343 Views

Hi @khtan,

No the card hasn't been programmed yet I'm in the process of building the BMC.
I will try pcie_aspm=off and let you know if it works. But before this I would rather confirm with the programmed board than this.

Thank you,
Best Regards

khtan
Employee
1,278 Views

Hi,

Just checking up on this, did you still see the AER error after programming the card?

 

Thanks

Regards

Kian

Beginner_in_FPGA
New Contributor I
1,261 Views

Hi @khtan

Even after programming the board AER error shows up. On RHEL 8.6 it doesn't show up. But in Ubuntu 22.04 the error pops up on bootup. I am yet to try with the below mentioned commands since I shifted to RHEL to build the BMC, will confirm with it on Ubuntu with the commands and let you know.

pcie_aspm=off
sudo update-grub


Thank you,

Best Regards.

khtan
Employee
1,017 Views

Hi,

Just checking up on this , whether did you manage to test on this or observe any issues with the card on Ubuntu other than the AER error?

 

Thanks

Regards

Kian

khtan
Employee
979 Views

Hi ,

I just did a quick check on my system running Ubuntu 22.04 , didn't get any AER errors when booting up. Probably need some setting there or ensure the card is programmed correctly.

 

If you require more time to test this since its not easy to keep switching OS just for testing, I would like to suggest to close this case first and once you tested on Ubuntu (with the pcie bitfurcation if you want as well), if the issue still persist , do submit another forum case or IPS case to us .

 

Thanks

Regards

Kian

 

Beginner_in_FPGA
New Contributor I
965 Views

Hi @khtan ,

Sorry for the delay in the response, I followed the steps you mentioned above in Ubuntu and still wasn't able to get the AER error to go away.
There are no other errors.
This AER error sometimes doesn't let the system boot, and sometimes the system does boot. So basically I have to be Restarting the system if the Boot fails.

On RedHat everything works fine, just in Ubuntu 22.04.

Thank you,
Best Regards.

khtan
Employee
957 Views

Hi,

Is both RHEL and Ubuntu running on the same machine and FPGA card (dual boot)? If yes, means Ubuntu config must be something wrong

 

Here is my Ubuntu grub (sudo nano /etc/default/grub), try set something like my configuration in bold

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="crashkernel=auto resume=/dev/mapper/cl-swap rd.lvm.lv=cl/root rd.lvm.lv=cl/swap rhgb quiet intel_iommu=on pcie=realloc hugepagesz=2M hugepages=200"

 

Wondering would it work if disabling AER, i saw some was saying on ubuntu bug forum to disable AER ( pci=noaer ) and their system boots up fine with this and didn't see any side effects. Could you try on pci=nommconf first

Copy from ubuntu forum

  • pci=noaer : this shoots the messenger, so to speak. Errors still occur, but they aren't reported, and system logs keep normal proportions.

  • pci=nommconf I've only recently heard about this one. It disables Memory-Mapped PCI Configuration Space, and reverts to the traditional handling of configuration space.

Just to check , did you install the OPAE/DFL (OFS) into Ubuntu?

 

Thanks

Regards

Kian

Beginner_in_FPGA
New Contributor I
566 Views

Hey @khtan sorry for the delay in responding,

I am using the same machine but different HDD one with Ubuntu and one with RedHat. 
I think there is something wrong with the grub configuration of Ubuntu.

I will check with the configuration you have given above and get back to you as soon as possible.

Yes OPAE/DFL is installed into Ubuntu.

 

Thank you,
Best Regards.

khtan
Employee
590 Views

Hi,

May I know whether any updates for this case?

 

Thanks

Regards

Kian

khtan
Employee
428 Views

Hi,

Unfortunately I didn't hear any response back and the case is open for sometime already. I will set it to close-pending first and transition for community support. If you manage to setup the configuration on ubuntu and see the AER error still, I would suggest to open a new thread and we will assist you from there.

 

Thanks

Regards

Kian

Reply