Application Acceleration With FPGAs
Programmable Acceleration Cards (PACs), DCP, DLA, Software Stack, and Reference Designs
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
404 Discussions

No files cached by aoc (Intel FPGA OpenCL compiler) even with AOCL_TMP_DIR set


I'm trying to shorten the compilation process by setting the AOCL_TMP_DIR to a folder in my home directory which I have write access too. But even after running OpenCL compilations multiple times with and without the -fast-compile flag, the folder still remains empty and the compilation takes as long as ever. (Reference Section 7.22 in the Programming Guide here

The compilation does print out this but nothing in it still.


AOCL_TMP_DIR directory was specified at <dir>.
Ensure Linux and Windows compiles do not share the same directory as files may be incompatible.
aoc: Cached files in <dir> may be used to reduce compilation time



I'm using the Arria 10 PAC devstack with Quartus 19.2 same as the DevCloud Arria 10 1.2.1 nodes.

It says here: that is was corrected in 19.1 but looks like it isn't.

0 Kudos
2 Replies

can you try not to define the $AOCL_TMP_DIR to your home directory, and let the tool to create by default.

I have tried that since that's the default. But that doesn't work too on my local machine.

Plus I need this for a shared cluster and need to redefine where the cache will be store so I do need the ability to change the default.