Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
18 Views

Possible flaw in Intel® Texture Works Plugin for Photoshop

I've been working with the Intel® Texture Works Beta Plugin for Photoshop, modifying DDS textures in for Fallout 4. I noticed a possible problem with the Intel plugin, which I hope the following will illustrate.

Here is the DDS opened with NVIDIA Texture Tools for Adobe Photoshop:

DDS opened with nVidia Photoshop Plugin.JPG

Notice that (a) there is an Alpha Channel, and (b) the RGB image is edge-to-edge, not trimmed to the alpha. The 3 blank poster images above the eyes are visible.

Here is the same DDS opened with the Intel® Texture Works Plugin for Photoshop:

DDS opened with Intel Texture Tools.JPG

Notice that the Alpha Channel has been applied to the image, removing the original RGB content. There is no distinct Alpha Channel to edit, only the transparency applied to the RGB. The 3 blank poster images above the eyes have disappeared.

I suspect that one of two things is true:
1) Those 3 blank posters are used as a texture asset in-game, and the Intel plugin is mistakenly applying the alpha, damaging the original content.
Or ...
2) The plugin is being accurate and efficient by removing alpha'd content, potentially saving filespace.

I don't have the means to discover which of those is more true. But it seems that forcibly removing the alpha may be the incorrect approach.

Thoughts? 🙂

0 Kudos
3 Replies
Highlighted
18 Views

Hey Niko,

Hey Niko,

I believe you are addressing an issue that has already been logged on the GitHub Issue site for the plugin. I appreciate your screen captures that better illustrate the problem to the plugin developers. Thanks for the input, it is duly noted and under review. Please use the same GitHub site above for any other bugs you may find.

Thanks again.
--
jaw

0 Kudos
Highlighted
Beginner
18 Views

Wonderful! Thank you, I'll

Wonderful! Thank you, I'll track it there.
Cheers,
Niko

0 Kudos
Highlighted
18 Views

This issue has been addressed

This issue has been addressed (and closed) in the latest release 1.0.4 with alpha handling options when opening a file.

Thank you

0 Kudos