Embedded Connectivity
Intel network controllers, Firmware and drivers.
645 Discussions

Bootutils reports unknown Flash for i210 - Trying to add PXE boot support

PJK
Beginner
600 Views

Trying to add PXE boot support for Intel i210 Gigabit Ethernet PHY, but bootutils does not recognize the flash. The tools lanconf64 and eeupdate work well. The Flash is programmed and the PHY operates normally, but it is not possible to configure PXE boot due to the fact that bootutils does not recognize the flash.

Please advise or suggest another way of enabling PXE boot.

 

Part number: WGI210IT_S_LJXT

Flash type: Winbond W25Q16JVSNIQ,

i210 image: Dev_Start_I210_Copper_NOMNG_16Mb_A2_3.25_0.03.bin

 

An example is added below using bootutils.efi, but the result is the same whether used in an OS or in the EFI shell.

 

0 Kudos
4 Replies
Mike_Intel
Moderator
579 Views

Hello PJK,

 

Thank you for posting in Intel Ethernet Communities. 

 

Base on your inquiry, we have specific forum for these issues and I will be transferring this thread for faster response. 


Please wait for their reply within 1 to 2 business days.


Thank you and stay safe.

 

Best regards,

Michael L.

Intel® Customer Support Technician


CarlosAM_INTEL
Moderator
566 Views

Hello, @PJK:

Thank you for contacting Intel Embedded Community.

We sent an email to the address associated with this account with information that may help you.

Best regards,

@CarlosAM_INTEL.

samwu0727
Beginner
344 Views

hi~ 

where can i download the PXE ROM for I210 ?

thanks a lot~ 

CarlosAM_INTEL
Moderator
334 Views

Hello, @samwu0727:

Thank you for contacting Intel Embedded Community.

We sent an email to the address related to this account with information that may help you.

Best regards,

@CarlosAM_INTEL.

Reply