Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
313 Views

How must the i210 Ethernet Controller be configured to establish a communication via RMII with a MC? Are there any examples or application notes?

 Hello,

I have problems with getting NC-SI interface on i210 running.. On our boards we are using Intel Ethernet Controller i210 for LAN Connection. Now I am trying to establish a NC-SI interface Connection between a microcontroller and i210 via RMII. I am sending a NC-SI select packet command from MC, but I am getting no reply from i210. Here is the complete packet: 0xffffffff, 0xffffffff, 0xffffffff, 0x88F80001, 0x0000011f, 0x00000000, 0x00000000, 0x00000000. To enable the NC-SI on i210 I set the Sideband Interface bits of the Common Firmware Parameters 1 to NC-SI (01b) with the Intel lanconf tool. But maybe other actions should be done to get NC-SI interface running. Please, could you give me a hint, what I additionally should do? Do you have an example, how to initialize NC-SI on i210?

Regards

Wolfram

 

 

0 Kudos
6 Replies
Highlighted
62 Views

Hello Wolfram,

 

Thank you for posting in Intel Ethernet Communities. Your query will be best answered by our Embedded Support team, we will help you to move this post to the designated team. Please feel free to contact us if any assistance is needed from Ethernet support team.

 

Best regards,

Crisselle C

Intel Customer Support

A Contingent Worker at Intel

0 Kudos
Highlighted
Moderator
62 Views

Hello, @WFitt​:

 

Thank you for contacting Intel Embedded Community.

 

Could you please clarify if the affected project is your design or a third- party one?

 

In case that it is a third-party device, could you please inform the name of the manufacturer, its model, the part number, and where its documentation is stated?

 

On the other hand, could you please let us know how many units of the project related to this circumstance have been manufactured? How many are affected? Could you please give the failure rate? Also, could you please list the sources that you have used to design it and if it has been verified by Intel?

 

We are waiting for your answer to these questions.

 

Best regards,

@Mæcenas_INTEL​.

0 Kudos
Highlighted
Beginner
62 Views

Hello, Thank you for your response. We developed a new main board for our ticket machines. As main CPU we are using Intel Atom E3825. The Intel Ethernet controller i210 is connected via PCIe to the CPU. On the board we also use an Intel FPGA Cyclone V GX with a NIOS II processor and an Ethernet MAC IP core, inter alia. Via RMII this MAC is connected to the i210 NC-SI interface. All components on the board are working fine and the board is going to get in serial production. But unfortunately the NC-SI interface i still have not got to run. Until now only 25 units have been manufactured as prototypes. I think the problem with NC-SI communication lies in the NC-SI initialization of the i210. Maybe I forgot something. I measured the RMII signals from the MAC and saw that the packets are transferred correctly. For the integration of the i210 in our board we used the Intel data sheet Rev 2.8 and the Intel design guide. With kind regards Wolfram http://www.initse.com<http://www.initse.com/>
0 Kudos
Highlighted
Moderator
62 Views

Hello, @WFitt​:

 

Thanks for your update.

 

We suggest you send the schematics and layout of your design to be reviewed by Intel. Please follow the procedure stated in the Design Review Services page that can be found at:

 

https://edc.intel.com/Tools/Design-Review/Default.aspx

 

We appreciate your collaboration.

 

Best regards,

@Mæcenas_INTEL​.

0 Kudos
Highlighted
Beginner
62 Views

Hello, I don’t think a review from Intel‘s side to be necessary. The i210 main Gigabit Ethernet communication is working very well. I only have problems with the side band interface NC-SI which is connected to the FPGA NiosII processor via RMII. The hardware connection of the RMII interface seems to be correct. I can see package transmission in Quartus II SignalTap. But I get no reply from the i210 controller. So I presume the i210 NC-SI interface not to be initialized correctly by my side. What registers values of the i210 controllers must be set to operate the NC-SI interface? Is the NC-SI control packet I am sending to the i210 correct? 0xffffffff, 0xffffffff, 0xffffffff, 0x88F80001, 0x0000011f, 0x00000000, 0x00000000, 0x00000000 Kind Regards Wolfram
0 Kudos
Highlighted
Moderator
62 Views

Hello, @WFitt (Customer)​:

 

Thanks for your reply.

 

Could you please confirm if you have used an NCSI NVM image from the devstarter package? It can be found in the Intel(R) Ethernet Controller I210 and I211-AT: Production NVM Images document # 513655, which is accessible that you are logged into your Resource & Design Center (RDC) privileged account at the following websites:

 

http://www.intel.com/cd/edesign/library/asmo-na/eng/513655.htm 

 

The RDC Account Support form is the channel to process your account update request. It can be found at:

 

https://www.intel.com/content/www/us/en/forms/design/contact-support.html

 

We are waiting for your reply.

 

Best regards,

@Mæcenas_INTEL​.

0 Kudos