Embedded Connectivity
Intel network controllers, Firmware and drivers.
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.

I210 Device ID

EE1
Beginner
376 Views

Hi

 

We use the I210IT Ethernet controller on our board.

At first, using lspci, the device was identified with device ID 1531 as expected.

 

After that we tried to update the chip's INVM using EEUPDATE /nic=x /invmupdate /file=xxx.txt

, and right now the chip is identified with a wrong device ID - 157a.

 

When using lspci command we get:
03:00.0 ethernet controller: intel corporation device 157a (rev 03)
When running ifconfig command we don't see the device.
We tried to use the EEUPDATE tool again, but since the chip doesn't have a nic number, we can't access it.

We also tried EEUPDATE with /device to change the ID number but no success - the tool doesn't detect the device.

How can we modify and update the i210 chip, so it will have a correct device ID like 157B or other valid device ID?

 

Thanks

0 Kudos
3 Replies
Mike_Intel
Moderator
342 Views

Hello EE1,


Thank you for posting in Intel Ethernet Communities. 


Base on your inquiry, we have specific forum for these issues and I will be transferring this thread for faster response. 


Please wait for their reply within 1 to 2 business days.


Thank you and stay safe.


Best regards,

Michael L.

Intel® Customer Support


CarlosAM_INTEL
Moderator
303 Views

Hello, @EE1:

Thank you for contacting Intel Embedded Community.

You should review that the affected designs fulfill the requirements that are stated as answers to questions 2.14, 2.15, 2.23, and 2.25; on pages 8 and 9 of the document stated on the following website:

https://cdrdv2.intel.com/v1/dl/getContent/334026

Best regards,

@CarlosAM_INTEL.

EE1
Beginner
287 Views

Hi Carlos

Thank you for your response.

I read the FAQ document that you referred to.

 

Let me explain the process again as I wrote in a previous message:

At first I used the EEUPDATE tool to program the iNVM using /INVMUPDATE /FILE=<filename>.

I used a text file to program the iNVM.

After that, the device got a device ID of 157a (detected using lspci command), which is not valid. Maybe there was a problem in the text file I used?

At this point, the EEUPDATE does no longer detect the i210 chip. When running the tool, it isn't shown in the list with a NIC number.

I also have an external flash on my PCB, I disconnected the MISO signal to make sure that the external flash is not causing this problem.

 

How can this be solved? I want to make the EEUPDATE tool detect the i210 again.

If I will pull down pin 12, will the i210 be accessible by the EEUPDATE again?

Also, even if I wanted to reconnect the external flash and try to program it instead of the internal iNVM, the i210 is not accessible by the EEUPDATE so this can't be done.

 

Thanks

Reply