Embedded Connectivity
Intel network controllers, Firmware, and drivers support systems
866 Discussions

Problems initializing the Intel 82567LM LAN Controller



i already wrote some test for Intel LAN Controllers and i am really happy about how easy it works with the Intel Chipsets.

But the 82567LM is causing some problems. Until know I just forced the MAC and the PHY to

operate with 100Mbps/fullduplex and everything worked fine.

With the 82567LM I don't even get an answer from the PHY over the MDIO register.

The MDIO register tells me that the read progress is done (Ready Bit set) but it always

returns zeros in the data field. I tried several reset strategies and setting the SW Semaphore

Flag, but there was no success.

I hope someone has experience with this controller and can tell me how to solve this.

My test system is an ICH9 Intel Chipset with the 82567LM.


Franziskus Karsunk

0 Kudos
1 Reply

Hi Franziskus,

Have you checked if the 82576LM PHY is powered and alive? I.e. does the PHY link after power-up? Do LEDs turn on? I"m asking in order to rule out any hardware issue with the PHY that might prevent it from responding to your code in your test.

Have you checked your code against our e1000e open source driver? Specifically comparing the PHY and semaphore usage when accessing MDIC register against our code. This needs to be followed exactly as the Intel driver.

You can get a copy of e1000e driver here:

http://sourceforge.net/projects/e1000/files/ http://sourceforge.net/projects/e1000/files/" rel="nofollow">http://sourceforge.net/projects/e1000/files/

Hope this is helpful. Let us know if there further questions.

-Aaron R.

0 Kudos