Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
2,107 Views

We are using AH-640 (Wifi+BT) Module, it has BCM43340 chipset and we are getting following logs on "netcfg wlan0 up" in ffrd8

===========================================================

[ 70.672038] Dongle Host Driver, version 1.88.61 (r)

[ 70.672038] Compiled in drivers/net/wireless/bcmdhd on Aug 5 2014 at 02:56:59

[ 70.687276] wl_android_wifi_on in

[ 70.691040] wifi_set_power = 1

[ 71.016965] mmc1: queuing unknown CIS tuple 0x80 (7 bytes)

[ 71.026037] mmc1: queuing unknown CIS tuple 0x80 (7 bytes)

[ 71.039253] mmc1: queuing unknown CIS tuple 0x80 (19 bytes)

[ 71.308720] =========== WLAN going back to live ========

[ 71.316790] dhd_bus_start: firmware = /system/etc/firmware/fw_bcmdhd.bin nvram = /system/etc/firmware/bcmdhd_aob.cal

[ 71.486119] dhdsdio_write_vars: Download, Upload and compare of NVRAM succeeded.

[ 71.661153] dhd_bus_init: enable 0x06, ready 0x06 (waited 0us)

[ 71.668000] bcmsdh_register_oob_intr IRQ=401 Type=1

[ 71.678122] Firmware up: op_mode=0x0015, Broadcom Dongle Host Driver mac=00:09:4c:53:78:2c

[ 71.700970] Firmware version = wl0: Mar 10 2014 12:09:56 version 6.10.190.49 (r460947) FWID 01-ca329f7b

[ 71.712976] dhd_interworking_enable: enableing interworking failed, ret=-23

[ 71.722829] iTCO_wdt: iTCO_wdt_keepalive

[ 73.724663] dhd_bus_rxctl: resumed on timeout, INT status=0x20000000

[ 73.733700] dhd_bus_rxctl: rxcnt_timeout=1, rxlen=0

[ 73.739209] CFG80211-ERROR) wl_dongle_up : WLC_UP error (-110)

[ 73.745941] CFG80211-ERROR) dhd_config_dongle : wl_dongle_up failed

[ 73.752981] CFG80211-ERROR) wl_cfg80211_up : __wl_cfg80211_up failed

[ 73.761202] =========== WLAN placed in RESET ========

[ 73.767169] netcfg (1739) used greatest stack depth: 3840 bytes lef

no permission to UP

================================================================

Can any one please enlighten that where the issue may be?

0 Kudos
13 Replies
Highlighted
Community Manager
28 Views

Hello Nikhil,

Welcome back to the Intel Embedded community.

We're working on your case and will post an update as soon as possible.

Are you by any chance using an Intel Edison?

Best regards,

Jimmy.

0 Kudos
Highlighted
Community Manager
28 Views

Hello Nikhil,

we're still working on this. In order to offer you the best support, please provide us with the following information:

1. Where did you obtained this logs from?

2. What OS are you using?

3. Can you please tell us if you're using an Intel Edison?

Best regards,

Jimmy.

0 Kudos
Highlighted
Novice
28 Views

Hi Jimmy, 

1. Where did you obtained this logs from?

We are using Baytrail-t processor.

 

Android source which we are using is byt_t_ffrd8_edk2_64-eng

The Android source has a binary driver for bcm4334x so the logs are from the same binary driver. This driver is working fine in our Reference board; the wifi module used in our reference is unknown but the chipset is bcm43341 and the one in out target board is has chipset bcm43340 (AW-AH640 module).

Actually AW-AH640 is a validated wifi module for baytrail-t

2. What OS are you using?

Android 4.4.4

3. Can you please tell us if you're using an Intel Edison?

No, we are not using Intel Edison.

Thanks.

Highlighted
Community Manager
28 Views

Hello Nikhils729,

Thanks for your reply.

We're still working on your case, once we have gathered enough information we'll write back.

In the meantime, could you please tell us if you have you tried running the command with su ?

Regards,

Jimmy.

0 Kudos
Highlighted
28 Views

Hello Nikhils,

We would like to know if you were able to run the command with su?

Please let us know your results.

Regards,

Gabriel Thomas.

0 Kudos
Highlighted
Novice
28 Views

without su I am not able to run netcfg command.

Above logs are with su.

0 Kudos
Highlighted
28 Views

Hello Nikhil,

We are going to further investigate the root of your issue.

Please stay tuned!

Regards,

Gabriel Thomas

0 Kudos
Highlighted
Community Manager
28 Views

Hello Nikhil,

thanks for your reply.

We are still working in your case.

Could you please tell us from where did you got the byt_t_ffrd8_edk2_64-eng source?

 

Regards,

Jimmy.

Highlighted
Novice
28 Views

Hello Jimmy,

We got the byt_t_ffrd8_edk2_64-eng source from Intel as we have NDA signed.

We are in final stage of development and all the interface except WIFI are working fine.

Please let me know if there are further clarifications to be made.

Hello Thomas,

Thanks we really appreciate this.

0 Kudos
Highlighted
28 Views

Hello Nikhil,

We have consulted this case with the Android experts, we are waiting for their feedback.

regards,

Gabriel Thomas

0 Kudos
Highlighted
Community Manager
28 Views

Hi Nikhil,

Sorry for the delay, we are still following up with our android experts.

Thank you for your patience!

0 Kudos
Highlighted
Community Manager
28 Views

Hello Nikhils729,

We have feedback from our Android experts.

It seems that most likely the WiFi module is not receiving interrupts.

1) Please check if the GPIO for OOB interrupt in the .cal file corresponds to the GPIO routing on this particular WiFi module. The parameter to check in the .cal file is:

# Enable the below for HW OOB on GPIO 4

# muxenab=0x2

sd_gpout=4

I have seen both GPIO 0 and GPIO 4 used.

2) Check the GPIO setup in the host. Is the GPIO coming from the BIOS or from the SFI table?

Please let us know this information.

Best regards,

Jimmy.

0 Kudos
Highlighted
Moderator
28 Views

Hello Nikhil,

Could you please let us know if you have any update related to this?

Thanks in advance for your reply.

Best Regards,

Carlos A.

0 Kudos