Community
cancel
Showing results for 
Search instead for 
Did you mean: 
bchav
Novice
1,596 Views

Windows 10 IoT GPIO test tool example failed in one of my Intel Atom based board.

Hi there,

I have successfully build the Windows 10 IoT sample example for GPIO test tool by changing target arch x86 in Visual Studio 2015. This is the link https://github.com/ms-iot/samples/tree/develop/GpioTestTool https://github.com/ms-iot/samples/tree/develop/GpioTestTool.

Deployment of the executable is also done in release mode in GB-TCV1 intel atom based board.

But After executing the executable the example code failed to find the GPIO Controller in the system.

What is going wrong can anybody help me!!!???

0 Kudos
10 Replies
CarlosAM_INTEL
Moderator
191 Views

Hello bhoomil,

Thank you for contacting the Intel Embedded Community.

We will contact you via email to help you.

Best Regards,

Carlos_A.

idata
Community Manager
191 Views

Hi, I am having the exact same issue. I am running the program on a Baytrail system.

It is not finding the GPIO controller. Can you please help?

idata
Community Manager
191 Views

Hi, did you find any solution to this yet?

CarlosAM_INTEL
Moderator
191 Views

Hello FA1115,

Thank you for contacting the Intel Embedded Community.

In order to help you we will contact you via email.

 

Best Regards,

Carlos_A.

191 Views

Hi Carlos,

Is this issue resolved? if yes, can you let me know what was the cause for the same

idata
Community Manager
191 Views

Header in Main.cpp says this is for WinRT.

idata
Community Manager
191 Views

I am running it in WinRT. This is the function that returns a null pointer, controllerStatics->GetDefault(controller.GetAddressOf()).

Adolfo_S_Intel
Moderator
191 Views

Hello,

I am taking care of the forum at the moment, since Carlos is not available.

I will ask some general questions about this issue, I hope I am not repeating questions:

1) The github sample application seems to be provided by Microsoft, has some of you contacted Microsoft support, to see if they are aware of the cause of the issue?

2) On what hardware platform are you running the sample application?

3)Have you made sure that you have installed all the required Intel Drivers for the platform before running the application? If possible try running the following Intel Utility connected to Internet: https://downloadcenter.intel.com/download/27336/IDUU-redirect?product=79577 Download IDUU redirect

4) What operating system are you using?

I will be waiting for your feedback.

Best Regards,

Adolfo Sanchez

191 Views

Hi,

I have not contacted Microsoft support.

I am trying to run it in Windows 10 IoT platform as well as Windows IoT core platform.

The Intel driver support assistant is showing that all my drivers are latest except the graphics driver.

Thanks,

Gokul

CarlosAM_INTEL
Moderator
191 Views

Hello, GOKUL_KRISHNAN :

Thaks for your update.

In order to help you, we will contact you via email.

Best regards,

Carlos_A.

Reply