Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
839 Views

getting IEGD to work on Linux...

Since two days we are trying to get IEGD to run on a Core2 Duo platform, without success...We tried kernels from 2.6.24 up to 2.6.30, vanilla and debian ones.Does anybody have any hints on this ?thanks in advance,Arne

0 Kudos
4 Replies
Highlighted
Valued Contributor I
12 Views

Hi Arne:

Welcome to the Intel® Embedded Design Center Community.

Let's see if someone out there may have some hints for you. In the meantime, have you checked out all the IEGD documentation? Below are a few links that discuss supported chipset, OS, and driver configurations:

http://www.intel.com/support/graphics/sb/CS-010512.htm http://www.intel.com/support/graphics/sb/CS-010512.htm" target=_blank>http://www.intel.com/support/graphics/sb/CS-010512.htm

http://edc.intel.com/Software/Downloads/IEGD/# overview http://edc.intel.com/Software/Downloads/IEGD/# overview" target=_blank>http://edc.intel.com/Software/Downloads/IEGD/# overview

http://www.intel.com/design/intarch/swsup/graphics_drivers.htm http://www.intel.com/design/intarch/swsup/graphics_drivers.htm" target=_blank>http://www.intel.com/design/intarch/swsup/graphics_drivers.htm

Also, can you say which chipset you are using?

Thanks,

Felix

0 Kudos
Highlighted
Beginner
12 Views

File Edit Options Buffers Tools HelpHello there and thanks for your reply.we have a GM45 based board (http://www.ibasetechnology.net/mi945.html), as an upgrade to a 945GME based board.Both have a Core2 duo processor.our target system is debian based (currently etch, but prototypes with lenny and sid)on the 945GME based board, we have a dual-DVI output (via a Chrontel chip), working with the etch xorg drivers and a custom 2.6.24 kernel, everything worked fine, but the displayed video wasn't perfect (29 fps conflicting with monitor at 60 Hz refresh rate)so we need to get the GM45 working, for now with the same dual-DVI setup, meaning one screen shows hardware accelerated video, and other screen shows controls.We could get the GM45 to work in single-screen mode with the 2009Q2 graphics pack, and it was perfect.Now we managed to get a VBIOS working (using the IEGD VBIOS compiler), allowing to have a dual screen, but without hw acceleration and kernel oops at modprobe.We tried like 10 different kernel compilations, to no avail.I wrote to the intel-gfx mailing list as well and put some links with more detailed information, cf http://lists.freedesktop.org/archives/intel-gfx/2009-August/003710.htmlI filled out a contact form on the EDC as well, with similar information.Right now, we are trying to get a fedora system to work, since fedora seems to be supported by the IEGD.Any (quick) help would be appreciated.Thanks in advance,Arne

0 Kudos
Highlighted
Employee
12 Views

The kernel versions you mention are not one of the ones listed as supported by IEGD. The embedded market tends to run at a slower pace than desktop or mobile applications so older distros are the norm.

The best thing to do is to use a kernel that matches one of the supported distros (or better- use a supported distro) then everything tends to work better.

The issue will be with either the GART or DRM mod that is needed for IEGD to operate. The "IKM" step during IEGD install (you did read the users guide, right?) attempts to patch those modules and if the version is not recognized, the patch fails and you will get panics and crashes from the driver.

The changes needed in the GART and DRM are small, but necessary and you might be able to look at what the patch attempts to modify and then apply that patch manually yourself to your kernel version. However, recently the DRM capability keeps getting changed (as well as recent updates to DRM2 cause all sorts of problems).

Hope this helps.

0 Kudos
Highlighted
Beginner
12 Views

please help on IEGD 10.1 on SLED/SLES11 (2.6.27.29-0.1)

# sh install.shFound kernel header files in /lib/modules/2.6.27.29-0.1-pae/buildBuilding for kernel 2.6.27If this is not the kernel you wish to build for, please set the KERNELDIRenvironment variable to the directory containing your target kernelsource tree.Checking the kernel dependencies... Verified the kernel dependencies./root/IEGD_10_1_Linux/IKMmake[1]: Entering directory `/usr/src/linux-2.6.27.29-0.1' CC [M] /root/IEGD_10_1_Linux/IKM/agp/pci.o/root/IEGD_10_1_Linux/IKM/agp/pci.c: In function 'iegd_intel_probe':/root/IEGD_10_1_Linux/IKM/agp/pci.c:256: warning: passing argument 1 of 'bridge_driver_init' from incompatible pointer type/root/IEGD_10_1_Linux/IKM/agp/pci.c: At top level:/root/IEGD_10_1_Linux/IKM/agp/pci.c:371: warning: initialization from incompatible pointer type CC [M] /root/IEGD_10_1_Linux/IKM/agp/global.o CC [M] /root/IEGD_10_1_Linux/IKM/agp/drv_alm.o CC [M] /root/IEGD_10_1_Linux/IKM/agp/drv_nap.o CC [M] /root/IEGD_10_1_Linux/IKM/agp/drv_plb.o CC [M] /root/IEGD_10_1_Linux/IKM/agp/drv_cmn.o CC [M] /root/IEGD_10_1_Linux/IKM/agp/drv_gn4.o CC [M] /root/IEGD_10_1_Linux/IKM/drm/iegd_drv.o CC [M] /root/IEGD_10_1_Linux/IKM/drm/iegd_interface.o CC [M] /root/IEGD_10_1_Linux/IKM/drm/iegd_interface_265.o CC [M] /root/IEGD_10_1_Linux/IKM/drm/iegd_interface_2611.o CC [M] /root/IEGD_10_1_Linux/IKM/drm/iegd_interface_2615.o CC [M] /root/IEGD_10_1_Linux/IKM/drm/iegd_interface_2624.o/root/IEGD_10_1_Linux/IKM/drm/iegd_interface_2624.c: In function 'intel_getpages_2624':/root/IEGD_10_1_Linux/IKM/drm/iegd_interface_2624.c:225: warning: assignment discards qualifiers from pointer target type CC [M] /root/IEGD_10_1_Linux/IKM/drm/psb_irq.o LD [M] /root/IEGD_10_1_Linux/IKM/iegd_mod.o Building modules, stage 2. MODPOST 1 modulesWARNING: "drm_irq_install" [/root/IEGD_10_1_Linux/IKM/iegd_mod.ko] undefined! CC /root/IEGD_10_1_Linux/IKM/iegd_mod.mod.o LD [M] /root/IEGD_10_1_Linux/IKM/iegd_mod.komake[1]: Leaving directory `/usr/src/linux-2.6.27.29-0.1'This will install the module to the /lib/modules/2.6.27.29-0.1-pae/kernel/drivers/char/agp.Is this ok? [y/n] yinstall -o root -g root -m 755 -d /lib/modules/2.6.27.29-0.1-pae/kernel/drivers/char/agpinstall -o root -g root -m 744 iegd_mod.ko /lib/modules/2.6.27.29-0.1-pae/kernel/drivers/char/agp/sbin/depmod -aInstallation completelinux-1ybh:~/IEGD_10_1_Linux/IKM # modprobe -f iegd_modFATAL: Error inserting iegd_mod (/lib/modules/2.6.27.29-0.1-pae/kernel/drivers/char/agp/iegd_mod.ko): Unknown symbol in module, or unknown parameter (see dmesg)linux-1ybh:~/IEGD_10_1_Linux/IKM # dmesg | tail[drm] Initialized drm 1.1.0 20060810iegd_mod: Unknown symbol drm_irq_installiegd_mod: no symbol version for struct_moduleiegd_mod: Unknown symbol drm_irq_installiegd_mod: Unknown symbol drm_irq_installiegd_mod: Unknown symbol drm_irq_installiegd_mod: Unknown symbol drm_irq_install

I see in my Module.symvers that there is no entry of that symbol? Am I missing something here? I followed the IKM steps from 10.1 manual.

Another question is how do I support 855GM chipset with IEGD8.0 on the same kernel? Its not listed in 10.1 but somehow in the source I see the chipset.

0 Kudos