Embedded Intel® Core™ Processors
Communicate Intel® Core™ Hardware, Software, Firmware, Graphics Concerns

5-tuple support on dpdk



I am trying to segregate data on basis of destination tcp/udp port and send them to different RX queues. From where different applications will read from their corresponding queues.

So I tried to implement 5 tuple filter but all the data is going to default RX queue 0 instead of setting destination to RX 1 or 2. I am using testpmd command for prototype purpose. Below is the command I am using.

5tuple_filter 0 add dst_ip src_ip dst_port 2049 src_port 32 protocol 0x06 mask 0x0 tcp_flags 0x0 priority 7 queue 2

and network card is

Intel Corporation 82599ES 10-Gigabit SFI/SFP+ Network Connection with dpdk-2.1.0 version.

Though Ether type filter is working on the same card which redirects data to different RX queues. But my requirement is segregation of tcp/udp port basis not on IP or ethernet port basis.

Please provide your valuable suggestions.



0 Kudos
2 Replies

Hello deepak,

Thanks you for contacting the Intel Embedded Community.

Please verify that you are following the guidelines stated in section 5.8.3, on pages 34 and 35 of the http://www.intel.com/content/dam/www/public/us/en/documents/guides/dpdk-testpmd-application-user-guide.pdf Testpmd Application User Guide Release 2.0.0.

Please let us know if this information is useful to you.

Best Regards,


0 Kudos

thanks for responding Carlos. Yes..I have been referring to same document from starting. Above command that I posted , have been taken from same document. I am using dpdk-2.1.0. Somehow all the packets are going to RX queue 0 and not RX queue 1. I went through different threads already present, but I could not find the root cause of this behaviour.

Is there any setup related requirements for this filter. Ethernet filter is working but 5 tuple filter is not working. I have seen statistics of different RX queue's using stat_qmap . Which register value should I check for 5 tuple filter to see if the filter was properly set. I think rss is implemented in test-pmd application which might be causing it anyway I have tried to disable it also.

I am having hard times configuring this filter .please help

0 Kudos