Community
cancel
Showing results for 
Search instead for 
Did you mean: 
NSahu
Novice
1,755 Views

Audio routing issue

Hi Team, I integrated the TLV320AIC3111 codec with intel Z3745 baytrail SOC. Driver is integrated and everything is working fine.

I have the pfw and xml file for routing, but there is not any alsa_amixer control for the right speaker, left speaker of my board are working but not right.

even i am changing the value using alsa command only left speaker bits are updated not for the right speaker. I got the files: pfw, xml, and codec driver

from intel SDK.

alsa_amixer -c baytrailaudio cget name='Right Output Mixer From DAC_R' is ON. I also attached the pfw, xml and driver with this.

Let me give some direction so i can make it workable? any help will be appreciate.

0 Kudos
6 Replies
idata
Community Manager
56 Views

Hello Nikhils729,

Welcome back to the Intel Embedded Community.

We're working on this case and will provide you with an update as soon as possible.

Best regards,

Jimmy.

Adolfo_S_Intel
Employee
56 Views

Hello Nikhils729

Please provide the following information

-What operating system are you using?

-Is it possible for you to test using a different operating system?

Best Regards,

Adolfo

NSahu
Novice
56 Views

Hi Adolfo,

we are using Android 4.4 (X86) OS. And it is not possible that i can try it with different OS because the SDK, Driver's and relevant things are based on Android 4.4 SDK.

We are going through the schematic (Hardware side) every thing is same both right and left speaker and only the one speaker is working.

Please update me ASAP.

Adolfo_S_Intel
Employee
56 Views

Hello Nikhils729

Thanks for your feedback, we are consulting this case with our Android experts, and we will update this with more information as soon as we receive their feedback.

Regards,

Adolfo

NSahu
Novice
56 Views

Can you guys please response quickly. what the need of you if we resolve our problem ourself everytime?

Adolfo_S_Intel
Employee
56 Views

Hello Nikhils729

I apologize for the delay on this reply.

My recommendation for you is to use the following support channels:

mailto:android-ia@lists.01.org android-ia@lists.01.org

https://software.intel.com/en-us/forums/android-applications-on-intel-architecture Android* Applications on Intel® Architecture

These channels are specialized on Android issues on Intel platforms and might be able to give you more advises regarding your issue.

Best Regards,

Adolfo.