Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MVale4
Beginner
6,517 Views

FPT for Linux

Hi,

i am not able to run the FPT on a current Linux (for example Ubuntu-16.04.1 with kernel 4.4.X) on a Atom E3845. I'm using the FPT from Kit 113607 / 1.1.4.1145v3_I_Converged_G01_20150707.

The error-message i get is sadly very unhelpful: "Attempt to Load on Incorrect OS" what does that mean? I traced the call and saw that the Application finds all the libraries it needs.

regards Markus

Tags (1)
0 Kudos
14 Replies
CarlosAM_INTEL
Moderator
529 Views

Hello, MarkuSValentin:

Thank you for contacting Intel Embedded Community.

In order to better understand this situation, could you please try to reproduce this situation using any of the Operating System (OS) listed on page 3 of the http://www.intel.com/content/dam/www/public/us/en/documents/platform-briefs/atom-processor-e3800-pla... Intel(R) Atom(TM) Processor E3800 Product Family for Intelligent Systems: Platform Brief document # 329621 and let us know the outcomes of this change?

Thanks in advance for your cooperation.

Best regards,

Carlos_A.

MVale4
Beginner
529 Views

Hi Carlos_A,

thanks for the reply. I did also try it on a (Fedora 24 (Workstation Edition)) with a 4.8.X Kernel with the same result:

"Attempt to Load on Incorrect OS"

Best regards

MarkuSValentin

CarlosAM_INTEL
Moderator
529 Views

Hello, MarkuSValentin:

Thanks for your update.

Could you please verify that you have implemented the suggestions stated in section 4, on pages from 38 to 49 of the https://edc.intel.com/Link.aspx?id=7018 Intel(R) Atom(TM) Processor E3800 Product Family/Intel(R) Celeron(R) Processor N2807/N2930/J1900 – Linux/Tizen/Android System Tools for Intel(R) Trusted Execution Engine [TXE] Firmware User Guide document # 527101? In case that you did not, please implement them and let us know the outcomes.

We really appreciate your collaboration.

Best regards,

Carlos_A.

MVale4
Beginner
529 Views

Hi Carlos_A,

i did check and i'm sure that all the suggestions are met.

Best regards

Markus

MVale4
Beginner
529 Views

Hi Carlos,

im really interested what that Message ist supposed to mean? Can you tell me?

Best regards

Markus

CarlosAM_INTEL
Moderator
529 Views

Hello, MarkuSValentin:

Thanks for your reply.

The information that may answer your last questions is stated in section 2.8, on page 13 of the https://edc.intel.com/Link.aspx%3Fid%3D7018 Intel(R) Atom(TM) Processor E3800 Product Family/Intel(R) Celeron(R) Processor N2807/N2930/J1900 – Linux/Tizen/Android System Tools for Intel(R) Trusted Execution Engine [TXE] Firmware User Guide document # 527101. In case that your implementation fulfills with the listed requirements, the cited message could be avoided.

We hope that this information may help you.

Best regards,

Carlos_A.

MVale4
Beginner
529 Views

Hi Carlos_A,

thanks for your reply and hanks for your hint.

I did execute TXEINFO and FPT on a Fedora 18 - 32bit with the TXE kernel driver modules installed and loaded. This fixes my previous error message "Attempt to Load on Incorrect OS".

I know get an other error-message while executing the TXEINFO or FPT: "Could not connect to the NAL Driver code: c86a8009" (while the driver modules are correctly loaded)

I tested this also on a current Linux Fedora 25 - 32bit where the TXE driver is mainline(and the modules are loaded), i get the same message as in Fedora 18 32 bit.

What am i missing?

Best Regards

Markus

CarlosAM_INTEL
Moderator
529 Views

Hello, MarkuSValentin:

Thanks for your reply.

We suggest you install first the TXEI driver on your Linux system and then run the FPT tool.

By the way, please review that your implementation fulfills the requirements stated in sections 2.9 and 6, on pages 14, 15, 16, 58, 59, 60, and 61 of the TXE Firmware User Guide document # 527101.

We hope that this information may help you.

Best regards,

Carlos_A.

AGust1
Beginner
529 Views

Hello Carlos_A,

now I'm facing this problem, too. The error message "Attempt to Load on Incorrect OS" is due to 32-bit FPT tool binary started in 64-bit Linux environment.

I cannot easily switch to 32-bit Linux. Is there a 64-bit version of the Flash Programming Tool for Linux?

Thanks,

Anatolij

CarlosAM_INTEL
Moderator
529 Views

Hello, agust:

Thank you for contacting Intel Embedded Community.

In order to be on the same page, could you please tell us the part number and SKU of the processor, also the Operating System (OS) related to your consultation?

Waiting for your reply.

Best regards,

Carlos_A

AGust1
Beginner
529 Views

Hello, Carlos

thank you for quick response.

The processor is an Intel® Atom™ E3845. The part number is FH8065301487717 (SR1X6). Currently the OS is Ubuntu 16.04.1 LTS, x86_64.

We also plan to use Yocto Project Core - Morty 2.2.1 x86_64 as the OS. FPT is supposed to be run under Morty 2.2.1 x86_64.

Best regards,

Anatolij

CarlosAM_INTEL
Moderator
529 Views

Hello, agust:

Thanks for your reply.

Based on your update, could you please try to reproduce this situation using any of the following Operating System (OS) and let us know the results?

- Microsoft Windows* 8.

- Windows Embedded Standard 8 (non-connected standby).

- Microsoft Windows 7.

- Windows Embedded Standard 7.

- Linux* Tizen (select in-vehicle infotainment (IVI) customers only).

- Linux based on Yocto Project* Tools.

- Linux based on Fedora* distribution.

- Microsoft Embedded Compact 7 and 2013.

- Wind River VxWorks*.

- Android* (JB MR2 4.3).

Thanks in advance for your cooperation.

Best regards,

Carlos_A.

AGust1
Beginner
529 Views

Hello Carlos,

I can not reproduce the error message "Attempt to Load on Incorrect OS" when running on 32-bit Fedora 18 (i686, Linux Kernel 3.11.10).

When running under this 32-bit Fedora 18 distribution, I've also seen the "Could not connect to the NAL Driver code: c86a8009" error,

as reported by Markus above. But I've resolved this by additionally loading the iqvlinux driver. So, the FPT and TXEInfo Tools can now run in the 32-bit environment.

The problem is that I cannot use 32-bit Linux OS. Our final product will always run a 64-bit OS (x86_64 configuration) with a newer Linux Kernel.

And I must run FPT tool under this 64-bit OS in production environment to write processor fuses for secure boot.

Thanks,

Anatolij

CarlosAM_INTEL
Moderator
529 Views

Hello, agust:

Thanks for your update.

Based on your replies, we suggest you use Operating Systems listed on page 3 of the https://www.intel.com/content/dam/www/public/us/en/documents/platform-briefs/atom-processor-e3800-pl... Intel(R) Atom(TM) Processor E3800 Product Family for Intelligent Systems: Platform Brief document# 329621 to avoid any inconvenience with the processor that you have mentioned.

We hope that this information is useful to you.

Best regards,

Carlos_A.

Reply