Community
cancel
Showing results for 
Search instead for 
Did you mean: 
AKhan19
Beginner
1,030 Views

Intel QuickAssist Technology 1.5 issue

I have a Lanner Product FW_7525b with Intel Atom™ processor C2358 and Intel Quick Assist Technology built in. I Installed Debian on it and tried Installing QAT1.5 as recommended by 01.org guides. During Installation the log Shows the following issue:

 

/root/QAT/quickassist/adf/drivers/common/linux/src/adf_proc_debug.c:140:21: error: void value not ignored as it ought to be

ret = seq_puts(sfile, (char*)file_info->page);

^

/usr/src/linux-headers-4.9.0-3-common/scripts/Makefile.build:298: recipe for target '/root/QAT/quickassist/adf/drivers/common/linux/src/adf_proc_debug.o' failed

make[7]: *** [/root/QAT/quickassist/adf/drivers/common/linux/src/adf_proc_debug.o] Error 1

/usr/src/linux-headers-4.9.0-3-common/Makefile:1507: recipe for target '_module_/root/QAT/quickassist/adf/drivers/common/linux/src' failed

make[6]: *** [_module_/root/QAT/quickassist/adf/drivers/common/linux/src] Error 2

Makefile:150: recipe for target 'sub-make' failed

make[5]: *** [sub-make] Error 2

Makefile:8: recipe for target 'all' failed

make[4]: *** [all] Error 2

make[4]: Leaving directory '/usr/src/linux-headers-4.9.0-3-amd64'

Copying outputs

mv: cannot stat 'adf_proc_debug.o': No such file or directory

mv: cannot stat 'adf_vf_bh.o': No such file or directory

make[3]: Leaving directory '/root/QAT/quickassist/adf/drivers/common/linux/src'

make[3]: Entering directory '/root/QAT/quickassist/adf/drivers/common/linux/src'

Building for linux_2.6

echo "copying /root/QAT/quickassist/adf/drivers/common/linux/src/build/linux_2.6/kernel_space//adf_driver_common.a to /root/QAT/quickassist/adf/build/linux_2.6"; \

cp /root/QAT/quickassist/adf/drivers/common/linux/src/build/linux_2.6/kernel_space//adf_driver_common.a /root/QAT/quickassist/adf/build/linux_2.6

copying /root/QAT/quickassist/adf/drivers/common/linux/src/build/linux_2.6/kernel_space//adf_driver_common.a to /root/QAT/quickassist/adf/build/linux_2.6

cp: cannot stat '/root/QAT/quickassist/adf/drivers/common/linux/src/build/linux_2.6/kernel_space//adf_driver_common.a': No such file or directory

Makefile:124: recipe for target 'copy' failed

make[3]: *** [copy] Error 1

make[3]: Leaving directory '/root/QAT/quickassist/adf/drivers/common/linux/src'

Makefile:89: recipe for target 'all' failed

make[2]: *** [all] Error 1

make[2]: Leaving directory '/root/QAT/quickassist/adf/drivers'

Makefile:117: recipe for target 'adf' failed

make[1]: *** [adf] Error 1

make[1]: Leaving directory '/root/QAT/quickassist/adf'

Makefile:155: recipe for target 'adf' failed

make: *** [adf] Error 2

Does anyone have the solution to this error? If one has please mention it below.

P.S.: I have tried the following solution : https://www.slideshare.net/MichelleHolley1/openssl-intel-r-quick-assist-technology-engine-setup-inst... https://www.slideshare.net/MichelleHolley1/openssl-intel-r-quick-assist-technology-engine-setup-inst... and it didnt work properly.(Building a sample Application became impossible)

0 Kudos
1 Reply
CarlosAM_INTEL
Moderator
83 Views

Hello, flappyShabeer:

Thank you for contacting Intel Embedded Community.

In order to be on the same page, could you please tell us if this problem persists if you use Wind River Linux BSPs or Linux Based on Yocto Project Operating System (OS)? In case that you ignore the answer, please use any of the Operating Systems, try to reproduce the issue and let us know the answer.

Finally, we would like to have the information related to support the affected third party board, but it is handled by its manufacturer. Due to this fact, we suggest you address your consultations associated to this project via the support channel of its developer.

We hope that this information may help you.

Best regards,

Carlos_A.

Reply