Community
cancel
Showing results for 
Search instead for 
Did you mean: 
KChan12
Beginner
507 Views

Running GLSL on RHEL 7.1

Processor: Intel Core i7-3555LE Processor with integrated HD4000 Graphics.

Operating System: RHEL 7.1

 

we have installed mesa opengl drivers.

We are running an OpenGL Application with GL Shading Language(GLSL) version 3.3

When we are compiling the OpenGL shader code it is throwing error(attached "compile_error.png").

 

We tried forcing the MESA_GL_VERSION_OVERRIDE and MESA_GLSL_VERSION_OVERRIDE to 3.3 and 330 respectively. didn't work.

Attached the log of glxinfo.

Can anyone suggest how to resolve this.

0 Kudos
1 Reply
CarlosAM_INTEL
Moderator
74 Views

​Hello, @KChan12​:

 

Thank you for contacting Intel Embedded Community.

 

The OpenGL consultations should be addressed as a reference to the channels listed in the following website:

 

https://community.khronos.org/

 

Best regards,

@Mæcenas_INTEL​. 

Reply