Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
140 Views

benchmarking QAT for HTTPs with wrk didn't work

Hello, here are some infomations:

1.QAT DEVICE INFO :

"qat_dev0 - type: dh895xcc, inst_id: 0, node_id: 0, bsf: 0000:03:00.0, #accel: 6 #engines: 12 state: up".

2. I've installed QAT async mode nginx accoding to https://github.com/intel/asynch_mode_nginx:

   ./configure \

       --prefix=$NGINX_INSTALL_DIR \

       --with-http_ssl_module \

       --add-dynamic-module=modules/nginx_qatzip_module \

       --add-dynamic-module=modules/nginx_qat_module/ \

       --with-cc-opt="-DNGX_SECURE_MEM -I$OPENSSL_LIB/include -I$QZ_ROOT/include -Wno-error=deprecated-declarations" \

       --with-ld-opt="-Wl,-rpath=$OPENSSL_LIB/lib -L$OPENSSL_LIB/lib -L$QZ_ROOT/src -lqatzip -lz -lssl"

make && make install

3.copy dh895xcc_dev0.conf from QAT_Engine Project to /etc, and there is SHIM section in it:

[SHIM]

NumberCyInstances = 1

NumberDcInstances = 0

NumProcesses = 32

LimitDevAccess = 0

# Crypto - User instance #0

Cy0Name = "UserCY0"

Cy0IsPolled = 2

# List of core affinities

Cy0CoreAffinity = 0

#No Data Compression here

 

4.vim NGINX_INSTALL_DIR/conf/nginx.conf:

   user root;

   worker_processes auto;

 

   load_module modules/ngx_ssl_engine_qat_module.so;

 

   events {

   }

 

   ssl_engine {

       use_engine qat;

       default_algorithms ALL;

       qat_engine {

       qat_offload_mode async;

      qat_notify_mode poll;

 

           qat_poll_mode heuristic;

       }

   }

 

   http {

   ssl_asynch on;

 

   server {

      listen      4430 ssl; #asynch;

          server_name localhost;

 

      ssl_protocols      TLSv1.2;

      ssl_certificate     /root/ll/m.io.top/m.io.top.crt

      ssl_certificate_key /root/ll/m.io.top/m.io.top.key

 

      location /test {

         default_type application/json;

         return 200 '{"status":"success","result":"QAT"}';

      }

 

      location / {

         root html;

         index index.html index.htm;

           }

       }

   }   

 

5.service qat start

 

6.NGINX_INSTALL_DIR/sbin/nginx

 

7.becnhmark from another server with wrk:

 

./wrk -t8 -c50 -d60s --latency -H "Connection: Close" https://m.io.top:4430/test 

 

The 8 CPUs were always 90%~100% with or without QAT enabled.

Requests/sec with QAT is around 17000, wihtout QAT is 22000, really strange.

 

 

0 Kudos
3 Replies
Highlighted
Beginner
103 Views

Re: benchmarking QAT for HTTPs with wrk didn't work

Plus the OS is Ubuntu 7.4.0-1ubuntu1~18.04.1. "uname -r" outputs 4.19.55​.

0 Kudos
Highlighted
Moderator
103 Views

Re: benchmarking QAT for HTTPs with wrk didn't work

Hello, @rmole​:

 

Thank you for contacting Intel Embedded Community.

 

Your Intel(R) QuickAssist Technology [QAT] consultations should be addressed as a reference to the channels listed at the following website:

 

https://01.org/community

 

Best regards,

@Mæcenas_INTEL​.

0 Kudos
Highlighted
Beginner
103 Views

Re: benchmarking QAT for HTTPs with wrk didn't work

Hi, Mæcenas:

Thanks for your reply.

We've figured it out. The problem has been solved by adding ssl_session_tickets off; in nginx.conf.

 

Best Regards,

gulue

0 Kudos