Community
cancel
Showing results for 
Search instead for 
Did you mean: 
RoyceDaniel
Novice
15,836 Views

23.5 ANS (Teaming) - Powershell CMDLet Hanging

Running all necessary commands to build a new team via Powershell just hangs after entering TeamName. I've also tried pipping 'Get-IntelNetAdapter | New-IntelNetTeam' which doesn't seem to do anything except ask for the first TeamMemberName on down to TeamName. It's acting like it's not accepting the pipped info. And yes, I'm running Powershell as the Administrator... any attempt to do so otherwise notifies you to run in Admin mode. All four adapters are active and have valid settings. All hardware/connection tests etc pass. This same hardware setup was working fine in the previous Windows/Intel Network software releases.

109 Replies
RoyceDaniel
Novice
1,789 Views

CTRL+C isn't working. Closing Powershell and relaunching works but I can't run additional "Intel" CMDLet's against the adapters. Launching the Intel PROSet Adapter Configuration Utility shows Loading: Adapter Information with no progress and a blank screen. It's like what ever the CMDLet is doing is locking up my adapters but yet I can still post here and surf around just fine on the Internet. I even tried turning on PowerShell transcription... it's not logging any kind of error after hitting enter on the last step of the New-IntelNetTeam CMDLet... I'm at a loss as to what to try next.

RoyceDaniel
Novice
1,789 Views

...oh and I've already tried bouncing all the Intel Services to see if any of the Services were stuck. The only thing that "unlocks" the adapters is to reboot.

RoyceDaniel
Novice
1,789 Views

Included the Intel PROSet Adapter Configuration Utility in the screen shot for reference in my previous response. Tried making a team with only two adapters instead of all four.

DFonz
Beginner
1,789 Views

I'm having similar issues: hanging when creating a team, cannot stop execution (CTRL+C or CTRL+Break), have to reboot in order to use IntelNetcmdlets again.

 

Hardware:

  • Intel Ethernet Connection I218-V

Software:

  • Windows 10, Version 1809 updated with KB4464330, KB4467708, and KB4469342 (Cumulative Updates for Windows 10 1809) and KB4469041 (Preview of Cumulative Update for .NET Framework 3.5 and 4.7.2 for Windows 10 1809)
  • Intel Network Adapter Driver for Windows 10, Version 23.5
MWebe5
Beginner
1,789 Views

I'm having the exact same issue with my Intel i350-t4v2 and the 23.5 drivers / software.

RoyceDaniel
Novice
1,789 Views

I could just be paranoid but it seems these new drivers aren't very stable. Occasionally my network connection will "freeze" up for a minute or two. Doesn't matter if I have 1 adapter enabled or 4. Locks them all up... similar to connecting to an unavailable network resource that locks up your UI for almost 90 secs waiting for the timeout. I'm going to roll back to 23.4 for a day to see if it clears up.

ZKłos
New Contributor I
1,789 Views

Same story here. Team creation just hangs and cannot be stoped with Ctrl-C. Windows has to be reboted to make Intel cmdlets usable again.

Windows 10 Pro 1809 with all latest updates and driver 28.5.

Intel I211-AT + I-219V

speedys4
Beginner
1,789 Views

Obviously same issue as well here. I just couldn't stop thinking why would Intel release a driver that remove the ability to set VLAN/Teaming from device manager and the PROSet utility. Seems like we're moving backwards here, sigh.

ElmerF
Novice
1,789 Views

I350, Windows 10 64 bit, 1809

Can manually add the 23.5 drivers by browsing to the uncompressed directory of 23.5 download. Tried to just do an iauto nstall, and the installer asks for some strange Intel CD and will not continue. Driver 23.4 was previously installed (installed fine) After a manual upgrade of the driver, when I run powershell, I get proper adapter info back, but I get nothing but errors back for the New- IntelNetTeam (command is there just doesn't work). I assume it's because proset did not update? Using an I350 dual adapter. Everything worked prior to 1809 using 23.3.

Daniel_D_Intel1
Employee
1,789 Views

Hello RoyceDaniel, Thank you for posting in Intel Ethernet Communities. Prior to performing the update to ANS 23.5 did you remove existing VLAN's and Teams, and uninstall existing ANS version? Please download the System Support Utility from the link below, and attach a log file for us to investigate this issue. 1- Download from https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows- 2- Open SSU.exe 3- Mark the box "Everything" and then click "Scan". 4- When finished scanning, click "Next". 5- Click on "Save" and attach the file to a post. Let us know if you have any other questions. Best regards, Daniel D Intel Customer Support
DFonz
Beginner
1,789 Views

Hi daniel.d_Intel

 

Not the OP, but have similar issues as mentioned ablve. I have tried Uninstalling ANS > Restarting > Installing ANS > Restarting > Attempt to create Team with no success and hanging. Attached is the log file from the SSU. 

 

Note: After attempting to create a Team using the IntelNetcmdlets, with the Powershell window subsequently hanging, I tried to run the SSU to create the log file, but the SSU was stuck at "Gathering Selected Information...". I had to restart my computer and re-run SSU without calling any IntelNetcmdlets in order for the scan to complete.

RoyceDaniel
Novice
1,789 Views

"Prior to performing the update to ANS 23.5 did you remove existing VLAN's and Teams, and uninstall existing ANS version?"

 

Of course. When RS5 came out the team was wiped out. No VLAN's on this machine. Ever since these large Microsoft updates started breaking ANS I've always uninstalled the Intel drivers and used the generic Microsoft drivers until your new package is released that supports the version of Windows I'm running. As I've mentioned in follow up posts yesterday the new drivers, even though the Powershell CMDLets aren't working I left it installed but I feel the drivers themselves are unstable. It would lock up my network connection for 60-90 seconds so I reverted back to 23.4 and everything has been fine since then from a normal non-teamed setup. I've never had any issues with ANS in previous Software release cycles. Given the number of consistent responses in this thread I don't know how much help this SSU dump will help but I've attached it to this response for your review.

 

Thank's guys!

ElmerF
Novice
1,789 Views

Files requested (1) - SSU output

ElmerF
Novice
1,789 Views

Files requested (1) - CD request during install

ElmerF
Novice
1,417 Views

Files requested - Powershell attempt after manual driver install

JustWantsToTeam
Beginner
1,789 Views

Same issue here.

Windows 10 1809 build 17763.194

I218V driver 12.18.8.4

I211 driver 12.15.184.1

Intel proset 23.5

CHead1
Novice
1,789 Views

I had all sorts of weird things happen but i didnt uninstall the old ones before upgrading to 1809. So I reverted back, uninstalled the intel, upgraded to 1809 and then the powershell tools work. HOWEVER, get-netadapter breaks the second you create a vlan.

 

S E:\programs\vmware> Get-NetAdapter

Get-NetAdapter : The data is invalid.

At line:1 char:1

+ Get-NetAdapter

+ ~~~~~~~~~~~~~~

  + CategoryInfo     : InvalidData: (MSFT_NetAdapter:ROOT/StandardCimv2/MSFT_NetAdapter) [Get-NetAdapter], CimE

  xception

  + FullyQualifiedErrorId : Windows System Error 13,Get-NetAdapter

 

 

Further more, i then had to uninstall the Intel drivers. It said it would delete the vlans (they still showed up in device manager although perhaps as a ghost adaptor which I removed). I then successfully reinstalled the drivers but experienced the same problems as above. The powershell commands would hang and control-C wouldn't work. Event viewer showed a whole stack of msi installer failures from intel in trying to create the vlans.

 

I reverted to a system state from before I originally installed the drivers. Reinstalled and now i have vlans again. But Get-NetAdapter is still broken.

 

I agree with the above people these drivers are not fit for use at the moment.

CHead1
Novice
1,789 Views

Oh, when it's in a broken state, you can't rename the network connection either... it just hangs.... i mean seriously, how to you get windows to hang trying to rename a network adaptor?

ElmerF
Novice
1,789 Views

Here is the SSU output and the screenshot of the request for CD during install.

ElmerF
Novice
1,789 Views

Here is the SSU output and the screenshot of the request for CD during install.

Reply