Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
4978 Discussions

Can't turn off SRIOV on CentOS 7 after its turned on

MYang241
Beginner
3,055 Views

I'm running CentOS 7 with a dual NIC nianctic (10G, ixgbe), and I have been experimenting with SRIOV.

I turned on SRIOV via the following command"

echo 8 > /sys/bus/pci/devices/0000\:01\:00.0/sriov_numvfs

However, this setting seems to be permanent. Even when I reboot, sriov_numvfs is is automatically enabled and set to 8. I don't have a startup script that is setting it.

I'm curious if there's a way to permanently disable sriov. I'm currently disabling it in a startup script, but because of ixgbevf, my Ethernet device ordering gets screwed up.

0 Kudos
6 Replies
SYeo3
Valued Contributor I
1,562 Views

Hi morganyang1982,

Thank you for contacting Intel.

On Linux Kernel version 3.8.x and above, VF can be destroyed or disabled by writing the value 0 to the sriov_numvfs parameter via sysfs interface.

# echo 0 > /sys/class/net/device name/device/sriov_numvfs

You can find the above-mentioned settings and other information on this http://www.intel.com/content/dam/www/public/us/en/documents/technology-briefs/xl710-sr-iov-config-guide-gbe-linux-brief.pdf Technical Brief.

Refer to page 12.

I hope this is helpful. Feel free to reply to us if you have further questions.

Sincerely,

Sandy

0 Kudos
MYang241
Beginner
1,562 Views

Hi Sandy:

Thanks for your reply, that method is what I'm using to disable SRIOV right now. However, as soon as the system reboots, sriov_numvfs becomes 8 again. Before I enabled SRIOV, it was always 0, but now I would have to reset it everytime the system reboots, which is not ideal. Is there another setting that is persisting across reboot?

Much Thanks

Morgan Yang

0 Kudos
SYeo3
Valued Contributor I
1,562 Views

Hi Morgan,

Thanks for replying.

I noticed you've entered the command "echo 8" instead of "echo 0", that's why you are seeing the sriov_numvfs value of 8. Make sure to change it to echo 0.

Hope this help resolve the issue.

Sincerely,

Sandy

0 Kudos
MYang241
Beginner
1,562 Views

Hi Sandy:

I have been using "echo 0" to disable SRIOV, however, as soon as I reboot the system, SRIOV becomes enabled again.

I initialy used "echo 8" to enable SRIOV for experimentation, I did not add that to any startup script or services, so I don't understand why SRIOV is being persistent across reboots.

In order for me to turn off SRIOV, I would have to "echo 0" every time after reboot in a startup script.

Sorry if I was not clear about my situation in the previous post.

Much Thanks

Morgan Yang

0 Kudos
SYeo3
Valued Contributor I
1,562 Views

Hi Morgan,

Thanks for the clarification.

Please provide the network card model that you are using so I can further check on the command and will update you.

Have a great weekend!

Sincerely,

Sandy

0 Kudos
SYeo3
Valued Contributor I
1,562 Views

Hi Morgan,

Good day. We would like to request for the model of network card that you are using so we may further look into this issue. Thanks.

Sincerely,

Sandy

0 Kudos
Reply