Ethernet Products
Intel® Ethernet products and technologies
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
3696 Discussions

Creating Vlans with the ProSet utility in windows 11 not working

xorinzor
Novice
3,885 Views

It seems PROSet would need an update for windows 11. Where it was working on windows 10 for me, it no longer works after the upgrade to 11.

Removed the drivers and utility, reinstalled both, still not working. The VLAN Adapters that are created will stay in a disabled state. Manually enabling them shows a "enabling.., enabled" message, but they will stay in their disabled state. Removing all VLANs and recreating them does nothing to resolve the issue either.

Running on a Dell Precision 7540, all latest windows & PROSet updates are installed.

0 Kudos
27 Replies
legacy1
Beginner
583 Views

So to be clear you are or are not going to support windows 11 for making VLAN's?

CrisselleF_C_Intel
Moderator
629 Views

Hello All,


How are you doing?


Please be informed that we will now close this request since we haven't received any response from our previous follow ups. Just feel free to post a new question if you may have any other inquiry in the future as this thread will no longer be monitored.


Thank you for the kind understanding and stay safe!


Best regards,

Crisselle C.

Intel Customer Support


Jayman
Beginner
612 Views

I was in the same boat but found an alternative. You have to enable HyperV services and its Powershell module.1.JPG

 

Then use Powershell to create a VMSwitch with the adapters.

New-VMSwitch -Name "External_network" -NetAdapterName "Ethernet"

Add-VMNetworkAdapter -ManagementOS -Name VLAN10 -SwitchName External_network

Set-VMNetworkAdapterVlan -ManagementOS -VMNetworkAdapterName VLAN10 -Access -VlanID 10

Then you will have the adapters and can configure the IPs accordingly.

 

Jayman_0-1632957273168.png

 

 



legacy1
Beginner
572 Views

@Jayman wrote:

I was in the same boat but found an alternative. You have to enable HyperV services and its Powershell module.




Thanks Jayman setup and running fine on win 11 with HyperV 

 

I do have to wonder what did MS break that stopped Intel way...maybe MS made allowances for Intel way and said we will not support you any more for win 11? 

sebasgst
Beginner
399 Views

Hi Jay, can you help me to create, an adapter with VLAN 400, and another Adapter with UNTAGGED, like vlan 1. Thanks!

The file below, shows how i used in Win10

Nodens
Beginner
483 Views

Hello,

 

This is VERY disappointing news. My company invested in Intel 710-DA2 NICs exactly because they allowed us to use NIC Teaming with Windows client OS that we use for our workstations. We are a software engineering company and our workstations, due to specific use case, need LAPC 2x 10G SFP+ aggregated links to our servers (Which run Fedora, as we work with cutting edge packages, with NIC Teaming on X710-DA2 cards just fine). We based our entire infrastructure on this design just 6 months ago. We also have to upgrade our workstations to Windows 11 for several reasons outside the scope of this post. This means our entire network, that we spent a lot of money on, is now crippled and our entire investment gone as we now have to redesign our infrastructure and invest in new costly hardware 6 months after our initial investment...
We had no notice whatsoever that Intel ANS would become obsolete from this point on and frankly this makes us lose our trust on Intel hardware. We should have gone with Mellanox and we will frankly avoid any further investments when its obvious that functionality may be revoked under our feet without any kind of warning or possible workaround.

As a second note we have also problems with RSS, which we require for SMB Multichannel as we serve multiple Vmware Workstation VM images to our workstations, with any version of the driver we tried. Specifically, as seen in the screenshot, we get a single RSS queue no matter the driver setting or whatever else we do. If we disable the port in Windows, RSS queue shows as 8, what is set in the driver, when we enable it, it gets set to 1. In the screenshot, "Synapse Beta" is the second, currently disabled, port while "Synapse Alpha" is the enabled port. They are both set up in the exact same way. We have checked the registry key and the value is as it is supposed to be. We have uninstalled and reinstalled the driver, reset the entire winsock stack, nothing works. When it comes to our settings, we just disable Interrupt Moderation and Flow control, we increase Transmit/Receive buffers to the max of 4096 and we enable 9014b Jumbo Packets. But we also tested default settings. Is this the kind of driver quality we can expect now from Intel?

 

Regards,

P. Kalogiratos
Abnormal Frequency Software

TehnoMag
Beginner
215 Views

Hello, colleges, i think, i found the solution.

1) Completly uninstall Proset utilities and device driver

2) Wait until generic driver will be installed by MS

3) Download and install 25th version of proset and install driver only

3a) If can not installed then download vendor drivers for device and update to 25th from it

4) Downaload and install 26th version and update driver only

5) Start installation again and add Proset and services
6) Start adding vlans via PowerShellConsole
7) Profit

 

PS C:\Users\delta> Get-IntelNetAdapter

Location Name ConnectionName LinkStatus
-------- ---- -------------- ----------
5:0:0:0 Intel(R) I211 Gigabit Network Connection 1,00 Gbps ...


PS C:\Users\delta> Get-IntelNetVLAN

VLANID VLANName ParentName
------ -------- ----------
0 Untagged Intel(R) I211 Gigabit Network Connection
106 VLAN106 Intel(R) I211 Gigabit Network Connection
1 VLAN1 Intel(R) I211 Gigabit Network Connection

 

Only one issue - is big delay before all interfaces are initialized

Reply