Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JLee157
Beginner
1,100 Views

How to enable rx-fcs parameter on XL710-QDA2 Adapter?

Hello Team,

 

I’m writing to make an inquiry about XL710-QDA2 (Dual 40GbE Port NIC).

My customer raised a question on rx-fcs parameters in NIC card (XL710-QDA2).

Customer is attempting to receive corrupted Ethernet frames by using rx-fcs & rx-all in ethtool.

The ultimate goal of this is to capture some errors frames.

By looking at the current configuration of the rx-fcs parameters in that NIC card,

It doesn’t seem to support this operation, which is fixed as OFF at firmware level. 

 

rx-fcs: off [fixed]

rx-all: off [fixed]

 

1.

Is there a way of enabling rx-fcs on Intel XL710-QDA2 (Dual 40GbE Port NIC)?

Since it looks to be hardware fixed, Is there any alternative way of this parameter configurable?

 

2.

If no way exists, then what other product do you recommend for this? (40Gbe dual )

It seems to be depending on NIC card.

some NIC allows the parameter configurable. but some doesnt.

 

 

Thanks always for your support

 

Regards,

Jae

0 Kudos
12 Replies
Daniel_D_Intel1
Employee
158 Views

Hello Jlee157, Thank you for posting in Intel Ethernet Communities. Please confirm if this is a retail version of the Intel XL710 QDA2 Ethernet Adapter or an OEM. Please provide an "ethtool -i <interface> output so we can see the drivers and firmware. We will use this information to further check on a solution. Let us know if you have any other questions. Best regards, Daniel D Intel Customer Support Under contract to Intel Corporation
CrisselleF_C_Intel
Moderator
158 Views

Hello Jlee157, Please provide the details that we require for us to further check on a solution. Let us know if you have any other questions. Best regards, Crisselle C Intel Customer Support Under contract to Intel Corporation
CrisselleF_C_Intel
Moderator
158 Views

Hello Jlee157, Please provide the details that we require for us to further investigate the issue. If you have any other questions, please do not hesitate to ask. Best regards, Crisselle C Intel Customer Support Under contract to Intel Corporation
JLee157
Beginner
158 Views

My apology for late response.

 

still awaiting the output of ehtool -i

 

The inquiry was about OEM one of  Intel XL710 QDA2 Ethernet Adapter

However I guess retail one is also same - rx-fcs disabled [Fixed]

2 questions

 

  1. curious If this is fixed at chipset level or Firmware level or both.
  2. If Intel has 40GbE NIC to make this parameter user configurable, I would suggest to my customer

 

Sorry again for late reply.

 

Thanks,

Jae

 

 

CrisselleF_C_Intel
Moderator
158 Views

Hello Jlee157, Thank you for the response. We'll wait for the output of the ethtool -i. We will check your inquiry and update you as soon as possible. Best regards, Crisselle C Intel Customer Support Under contract to Intel Corporation
CrisselleF_C_Intel
Moderator
158 Views

Hello Jlee157, Thank you for waiting for our update. Please try to do the following commands and let us know of the results. ethtool -K eth0 rx-fcs on ethtool -K eth0 rx-all on If you have any other questions, please do not hesitate to ask. Best regards, Crisselle C Intel Customer Support Under contract to Intel Corporation
JLee157
Beginner
158 Views

Thanks Crisselle,

 

As seen below, It seems not possible to enable the offload If "fixed"

# ethtool -K eno1 rx-fcs on

Could not change any device features

# ethtool -K eno1 rx-all on

Could not change any device features

 

I assume that the Intel NIC does not support HW FCS at NIC's chip level (not FW level), which means there is no way of FCS possible?

What I'd like to know is

1.If this "Fixed" is at chip level fixed ?

2.Any suggestion for further debugging regarding bad frame (CRC error)?

 

 

Thanks again

Jae

 

CrisselleF_C_Intel
Moderator
158 Views

Hello Jlee157, Thank you for providing the output of ethtool -K eth0 rx-fcs on and ethtool -K eth0 rx-all on. We will check on this and we'll get back to you as soon as possible. Hoping for your patience. Best regards, Crisselle C Intel Customer Support Under contract to Intel Corporation
CrisselleF_C_Intel
Moderator
158 Views

Hello Jlee157, Thank you for waiting for our update. May I know if you are using the latest ethtool and if the drivers are updated to it's latest version? If not, please try to use the latest ethtool and update the drivers. After then please try to run again the given command before. Please let us know of the results. Best regards, Crisselle C Intel Customer Support Under contract to Intel Corporation
CrisselleF_C_Intel
Moderator
158 Views

Hello Jae, May I know if you were able to run the given command using the latest ethtool and drivers? Please let us know of the results. If you have other questions, please do not hesitate to ask. Best regards, Crisselle C Intel Customer Support Under contract to Intel Corporation
JLee157
Beginner
158 Views

Hi Crisselle,

 

Thanks for your follow-up

no chance to update ethtool version, However the driver is latest one.

Regardless of the version of ethtool & driver, I assume that it is h/w fixed at Chip level or FW level.

The customer seems to be figuring it out via a different way. so we no longer need to go further .

 

Many thanks Crisselle again for your support and advice

 

Cheers,

Jae

CrisselleF_C_Intel
Moderator
158 Views

Hello Jae, Thank you for the update. If you have additional questions in the future, please do not hesitate to ask. Best regards, Crisselle C Intel Customer Support Under contract to Intel Corporation
Reply