Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,403 Views

Integrated Intel 82577 network controller - EEPROM failure

I have integrated Intel 82577LM Gigabit Network Controller installed in my E6510.

After installing updated driver from Intel and running hardware test it stopped working (displays "This device cannot start. (Code 10)" in driver details page).

 

Also it says that device is 82577LC (it used to be 82577LM).

Intel hardware test displayed "EEPROM Failure" message. Looks like this test damaged network card firmware somehow.

 

How do I restore/reset EEPROM of the network cad?

I also tried deinstalling and reinstalling previous version of driver from Dell - nothing helps.

Please advice.

0 Kudos
3 Replies
Mark_H_Intel
Employee
91 Views

The EEPROM memory is not affected by the driver or the hardware test. So changing driver versions will not help. You will need assistance from Dell to resolve the issue.

Mark H

BFawk
Beginner
91 Views

I have the exact same problem on a T410. I had just loaded a driver and was running a speed test, and the connection started going up and down very quickly over and over. When I rebooted the machine, the interface has never worked since. I uninstalled and reinstalled every driver that would work, and always get the same error code 10 cannot start. why is the original question unanswered for over 1 year?

XNYC
Beginner
91 Views

Have similar problems on TWO Thinkpad T410 and a Thinkpad W510. In one T410, the nic reports the network cable is not connected (it ism and is good/connected), in the ohter the connection is unreliable, will drop every once in a while when connected to its laptop base (which works with other laptops, also tested on other good bases). On the W510 it just does not work. In all cases, drivers were uninstalled/ reinstalled/ updated, and even previous images of the system when the nic was working were restored.

So it seems there is some kind of hardware rot taking place there. The wifi is fine, and a workaround is to use an USB nic connection, somewhat annoying.

I wish there were some software tool to diagnose /confirm this is a hardware/ firmware issue.

Reply