Ethernet Products
Intel® Ethernet products and technologies
3880 Discussions

Intel I350-t2 is not recognized by Linux (centos, ubuntu)

ItsJackWang
Beginner
655 Views

I have an intel I350-t2 and it's not recognized by Linux(both centos7/8 and ubuntu 18.04). I think I had exactly the same problem as mentioned here .

 

I tried to update the firmware and I saw two ports by command "bootutil64e". But after I run "bootutil64e -UP=PXE -ALL -FILE=../BootIMG.FLB", I got "Cannot initialize adapter" with both ports. Same result with "bootutil64e -ALL -defcfg". What should I do next?

Thanks in advance.

 

pic1.jpegpic2.jpegpic3.jpeg

 

 

 

0 Kudos
6 Replies
Crisselle_Intel
Moderator
626 Views

Hello ItsJackWang,


Thank you for posting in Intel Ethernet Communities. 


Please provide the following information that would help in checking your request.

1. Driver and firmware version of the adapter. 

2. PBA number of the adapter for us to identify if you are using an Original Equipment Manufacturer(OEM) or retail version of Intel Ethernet Adapter. You may refer to the link below on where to find the PBA number. It consist of 6-3 digit number located at the last part of the serial number. 

Identify Your Intel® Network Adapter Model Using PBA Number

https://www.intel.com/content/www/us/en/support/articles/000007022/network-and-i-o/ethernet-products...

3. Have you tried installing the adapter on Windows OS? If yes, do you encounter the same issue?

4. You mentioned 'I tried to update the firmware', can you share the link where the package was downloaded from?


Looking forward to your reply.


We will follow up after 3 business days in case we don't hear from you.


Best regards,

Crisselle C.

Intel® Customer Support


ItsJackWang
Beginner
609 Views

Dear Crisselle,

 

Thanks for taking up on this support request.

1. I've tried different versions including igb-5.5.2, igb-5.3.5.5 and none of them works. I was basically following this link: https://downloadmirror.intel.com/13663/eng/readme_5.5.2.txt  to install the driver. I saw corresponding version was loaded through "modinfo igb" but os still failed to recognize the adapter.

the first time when I run command "bootutil64e", I saw Post1 with version 1.5.50 and Port2 Flash disabled. After I updated the firmware(I am not sure it succeeded or not) with BootIMG.FLB(version=v1.5.89), It seems that I am not able to do anything by command bootutil64e as the error message says "Cannot initialize adapter".

2. PBA number: G93550

3. No, I did not try it on windows os

4. The package was downloaded from https://downloadcenter.intel.com/download/29137?v=t 

 

Crisselle_Intel
Moderator
601 Views

Hello ItsJackWang,


Thank you for providing the requested information.  


Please allow us to further check on your query. We will get back to you as soon as possible but no later than 2-3 business days. 


Hoping for your kind patience. 


Best regards,

Crisselle C.

Intel® Customer Support


Crisselle_Intel
Moderator
557 Views

Hello ItsJackWang,


Thank you for the patience on this matter. 


After checking, we have confirmed that the adapter you are using is Lenovo Original Equipment Manufacturer(OEM) version. For OEM version of Intel Ethernet adapters, it would be best if you can get in touch with manufacturer for further support since they have customized drivers, firmware and software to enable or alter features on your card. They are in best position where you can seek assistance so you don’t lose features or customizations of the Ethernet adapter. 


The software package should be supplied by your manufacturer. The package you are currently using might not be compatible on your OEM adapter so we highly suggest consulting this with them. They are also in best position to seek an assistance on where to download the package as well as how to apply the update. 


Please also share the following information with us.

1. When was the issue first encountered? Is it during initial integration or the Ethernet adapter worked fine before?

2. What is the brand and model of the system where the adapter was installed? Have you confirmed with your manufacturer that the card was validated on the system.

3. Sharing with you the Upgrade, Enable, or Disable Flash with the Intel® Ethernet Flash Firmware Utility for more information.

https://www.intel.com/content/www/us/en/support/articles/000005790/software/manageability-products.h...


Looking forward to your reply.


We will follow up after 3 business days in case we don't hear from you.


Best regards,

Crisselle C.

Intel® Customer Support


Crisselle_Intel
Moderator
536 Views

Hello ItsJackWang,


Good day!


This is just a follow up to check if you have read our previous message. If yes, kindly confirm and provide the additional information requested for further investigation. 


Awaiting to your reply. 


Should there be no response from you, we will follow up after 3 business days.


Best regards,

Crisselle C.

Intel® Customer Support


Mike_Intel
Moderator
484 Views

Hello ItsJackWang,


Good day!


We are just sending another follow up on the information that I requested. 

Since we have not heard back from you, I need to close this inquiry. 


If you need further assistance, please post a new question. 


Best regards,

Michael L.

Intel® Customer Support


Reply